Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#23985 closed defect (bug) (wontfix)

Twenty Thirteen: Genericons don't work in IE9 Mobile

Reported by: celloexpressions Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords:
Focuses: Cc:


IE9 Mobile is absolutely the ONLY browser available on Windows Phone 7.5/7.8 devices. 7.8 devices are still being sold, particularly in developing markets. Market share is bigger than you might think, and unfortunately in this case not supporting this browser means not supporting these devices. That makes me wary of relying on Genericons as widely as I'd like, and I'm sure others feel the same. At the moment, Genericons don't work at all in IE9 mobile. They display as rectangular boxes (same symbol as missing image). They're fine on WP8 devices (running IE10 mobile).

To reproduce, visit genericons.com or any site running a variant of Twenty Thirteen on a Windows Phone 7 device.

The issue seems to be with Genericons in general, but I'm not sure where the best place to report this is, so I'm starting here, since it also makes a mess out of Twenty Thirteen. The new Dashicons in MP6 don't work either (making the admin completely unusable), so it may be an icon font issue in general, and difficult to fix. If they didn't work in Twenty Thirteen it wouldn't be the end of the world, but ideally they should, of course. The Dashicons thing shows how problematic things are if we rely on them too much for UI and they don't work.

Change History (3)

#1 @lancewillett
3 years ago

  • Keywords close added

I agree for the admin dashboard it's a more important issue, and in that case image-based versions could be made for all icons.

With Twenty Thirteen, however, icons can be colored for *any* color, so it's not feasible to create image fallbacks.

I'd vote to "wontfix" and have it be a known issue with this particular mobile browser.

#2 @lancewillett
3 years ago

Oh, forgot to mention -- I forwarded your report to Joen Asmussen, the author of Genericons. He is now aware of the issue.

#3 @lancewillett
3 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.