WordPress.org

Make WordPress Core

#23996 closed defect (bug) (fixed)

Twenty Thirteen: Gallery Captions display incorrectly in IE 8

Reported by: celloexpressions Owned by: lancewillett
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords: has-patch commit
Focuses: Cc:

Description

The captions are always displayed over the images, with white text but no background. See screenshot.

Note: emulating IE 8 with IE 10

Attachments (7)

twenty-thirteen-gallery-captions-ie8.png (143.7 KB) - added by celloexpressions 13 months ago.
Screenshot of gallery with captions in IE8 (on index.php page)
23996.diff (425 bytes) - added by obenland 13 months ago.
Avoid galleries not being displayed on single.
23996.2.diff (527 bytes) - added by kovshenin 13 months ago.
23996.3.diff (721 bytes) - added by celloexpressions 13 months ago.
Fix gallery caption display for IE 7&8
23996.4.diff (362 bytes) - added by kovshenin 13 months ago.
23996.5.diff (658 bytes) - added by obenland 13 months ago.
23996.6.diff (738 bytes) - added by obenland 13 months ago.

Download all attachments as: .zip

Change History (24)

celloexpressions13 months ago

Screenshot of gallery with captions in IE8 (on index.php page)

comment:1 kovshenin13 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.6

Reproduced on IE8 under Windows 7. The gallery is not displayed at all on a singular page, unless IE is switched to Compatibility View.

obenland13 months ago

Avoid galleries not being displayed on single.

comment:2 obenland13 months ago

  • Keywords has-patch added; needs-patch removed

IE8 does not support CSS3 transitions or transparent backgrounds. We could provide a fallback with a solid color, but this might make it worse than it is now. I'd prefer to leave it as is, it's an old browser.

I added a fix for the non-displaying galleries.

comment:3 RDall13 months ago

  • Cc robert@… added

comment:4 kovshenin13 months ago

Replying to obenland: I think a fallback solid color is better, because it at least ensures that the text is readable. Think the white captions applied to something on a white background, like the bottom-left example in the attached screenshot.

comment:5 lancewillett13 months ago

+1 for a solid background for IE8 captions.

comment:6 lancewillett13 months ago

In 23943:

Twenty Thirteen: avoid galleries not being displayed on single in IE8, props obenland. See #23996.

comment:7 celloexpressions13 months ago

Solid background would be fine. If you're willing to use filter: alpha(opacity=x), that would allow it to only display on hover (set to 0 on .gallery-caption, maybe 80 on .gallery-item:hover .gallery-caption), in which case the solid background is no problem (and the whole caption+background would be slightly transparent if using less than 100).

The two issues here for 8 are really just opacity and using rgba, 9 also doesn't get the transition (10 does), but that's just extra.

kovshenin13 months ago

comment:8 kovshenin13 months ago

Unfortunately [23943] didn't do the trick for IE8. Here's what I see: http://cl.ly/image/1j2y1q463C2j

23996.2.diff attempts to fix the gallery display in non-compat mode and adds a semi-transparent background. I also noticed that the ie.css stylesheet is not loaded at all during Compatibility View.

comment:9 obenland13 months ago

Is it just an IE8 issue or can we catch IE7 with that too?

celloexpressions13 months ago

Fix gallery caption display for IE 7&8

comment:10 follow-up: celloexpressions13 months ago

23996.3.diff adjusts to fix captions for both IE7 and IE8, as well as only displaying them on image hover (as is the behavior in other browsers). Sorry, it's my first patch so I probably didn't do it quite right but it should work against what's in core now (in the future, should the patch require applying previous patches first or work against core, and what if a patch has already been committed as in this case?).

I can confirm that the single view still doesn't work (note: there is another bug in the emulator that makes it look fine if you're using IE10 as 8), although I think that's a separate issue, should it move to a separate ticket?

Version 0, edited 13 months ago by celloexpressions (next)

comment:11 in reply to: ↑ 10 SergeyBiryukov13 months ago

Replying to celloexpressions:

(in the future, should the patch require applying previous patches first or work against core, and what if a patch has already been committed as in this case?).

Patches should be made against current trunk, without requiring previous ones. 23996.3.diff seems correct in that regard.

comment:12 obenland13 months ago

  • Keywords commit added

Patch looks really good. Nice job kovshenin and celloexpressions!

comment:13 lancewillett13 months ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 23959:

Twenty Thirteen: display gallery captions correctly in IE7 and IE8. Props celloexpressions and kovshenin, fixes #23996.

kovshenin13 months ago

comment:14 kovshenin13 months ago

  • Keywords commit removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry to be such a pain, but [23959] is not doing it either. Since .3 dropped the .ie8 part, the .gallery-item selector is not specific enough and is being overridden by .gallery-columns-* .gallery-item selectors in the main stylesheet, at least for IE8. 23996.4.diff should hopefully fix that.

I'm using IE 8.0.7601.17514 running Windows 7.

obenland13 months ago

obenland13 months ago

comment:15 obenland13 months ago

  • Keywords commit added

Nice catch, kovshenin, thanks!

Apparently the last, big, image in each gallery in the new Theme Unit Test prevented me from seeing the bug kovshenin saw.
Irregardless, .6 should fix this once and for all.

comment:16 kovshenin13 months ago

Woot! .6.diff works like a charm.

comment:17 lancewillett13 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 23963:

Twenty Thirteen: improve gallery styles for IE7 and IE8, props kovshenin and obenland. Fixes #23996.

Note: See TracTickets for help on using tickets.