WordPress.org

Make WordPress Core

#24012 closed defect (bug) (wontfix)

Twenty Thirteen: Bitter Font not loading in IE8

Reported by: RDall Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Bitter Font not loading as originally mentioned here:
http://make.wordpress.org/core/2013/04/08/twenty-thirteen-tasks-and-priorities-during-beta-period/#comment-8364

IE 8 on Windows 7 doesn't load the Bitter font. See Screenshot: http://cl.ly/image/0t033l0I3K1N

The font is being properly called in the font-family css it is just not being loaded.

This is only affecting IE8… IE9 has the same css (as seen in the developer window)

Attachments (1)

24012.diff (1.2 KB) - added by obenland 15 months ago.

Download all attachments as: .zip

Change History (15)

obenland15 months ago

comment:1 obenland15 months ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Awaiting Review to 3.6

Apparently IE has problems to recognize multiple fonts in one request to Google fonts.

I doubt my patch is the best solution. Chances are that the paths it references change in the future. But it's a start.

comment:2 celloexpressions15 months ago

That's better but it only loads the bold variant, so perhaps the problem is with the regular variant in general.

In case it helps, this is the error that IE gives me:

CSS3111: @font-face encountered unknown error. 
m9utyiSe0RUNoAmpferM-g.eot

With the patch, it gives the previous and this:

CSS3111: @font-face encountered unknown error. 
XexqN1a_o27MhVVdJFKAcA.eot

Both of those URLs correspond to the regular version.

comment:3 obenland15 months ago

Huh, wasn't even looking for that. Only appear in IE8 on win7. Weird.

Version 0, edited 15 months ago by obenland (next)

comment:4 obenland15 months ago

Apparently the error CSS3111 is usually caused by an issue with the font's binary source.

I'm not sure how much we can do about that on our end. Having the bold version is a step in the right direction, though.

comment:5 lancewillett15 months ago

I think it's an OK trade-off for the font to fall back in IE8 to the font stack we have in place. Georgia does a good job as second choice. :)

comment:6 follow-up: lancewillett15 months ago

Also:

IE 8 on Windows 7

How often will that be the case? Windows 7 shipped with IE9 as default browser; how likely that someone would know how to downgrade it?

comment:7 obenland15 months ago

I don't mind going with Georgia either. That's what a fallback is for ;)

comment:8 in reply to: ↑ 6 celloexpressions15 months ago

Replying to lancewillett:

Also:

IE 8 on Windows 7

How often will that be the case? Windows 7 shipped with IE9 as default browser; how likely that someone would know how to downgrade it?

Windows 7 actually ships with IE8, and unfortunately I know people who refuse to update. Most Win7s are updated to IE9 (now 10) though. That + XP is why there's still such a large market share.

Georgia's just fine, unless we just want to load Bitter Bold.

comment:9 follow-up: lancewillett15 months ago

Weird that Source Sans loads OK. Did anyone research if this is a known bug with Google Webfonts?

comment:10 in reply to: ↑ 9 rdall15 months ago

Replying to lancewillett:

Weird that Source Sans loads OK. Did anyone research if this is a known bug with Google Webfonts?

I know I saw that too so I though it was because we didn't load bitter properly… Why would a bug effect one font and not the other?

comment:11 lancewillett15 months ago

Since the other font, and the Bitter bold weight loads OK, sounds more like a bug in the binary file on Google's end. Anyone up for researching and reporting it to Google Webfonts team? (If they have a bug tracker, that is.)

comment:12 rdall15 months ago

Submitted issue ticket to Google Font Directory Forum.

http://code.google.com/p/googlefontdirectory/issues/detail?id=212

Suggest we close ticket as we can't fix the problem it is external.

comment:13 lancewillett15 months ago

  • Keywords reporter-feedback added; has-patch removed
  • Milestone changed from 3.6 to Awaiting Review

Moving into Awaiting Review so we can remember to follow up on it.

comment:14 lancewillett15 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.