WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 15 months ago

#24019 closed enhancement (wontfix)

Allow user to specify image size when selecting "Media File" as "Link To" target for image attachments.

Reported by: dfcowell Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords: has-patch
Focuses: ui Cc:

Description

Currently selecting "Media File" as the "Link To" target causes an embedded image to link to the originally uploaded file. These files can be very large and there is no way to non-destructively resize them on upload while retaining this "Link To" functionality.

This enhancement patch adds a drop down list of available image sizes to the form (defaulting to Full Size - the existing behaviour) when "Media File" is selected, allowing the user to link to custom image sizes as specified in their themes or plugins if desired.

http://dfcowell.net/wp-content/uploads/2013/04/attachdisplay.png

http://dfcowell.net/wp-content/uploads/2013/04/attachdisplay2.png

This is a significant improvement over default functionality, especially when used in conjunction with a lightbox plugin. It allows the user to retain the full-size image on the server while being able to specify a link to a smaller size if desired.

Attachments (1)

media.patch (3.4 KB) - added by dfcowell 2 years ago.
Media File Patch

Download all attachments as: .zip

Change History (8)

@dfcowell2 years ago

Media File Patch

comment:1 @SergeyBiryukov2 years ago

#15668 was marked as a duplicate.

comment:2 follow-up: @dfcowell2 years ago

Not strictly a duplicate of #15660 as it references the existing Size field used to generate img tags and handling the registration of custom/default image sizes.

This enhancement creates a new field under "Link To" which affects the anchor tag generated when an image is embedded.

Version 0, edited 2 years ago by dfcowell (next)

comment:3 in reply to: ↑ 2 @SergeyBiryukov2 years ago

Replying to dfcowell:

Not strictly a duplicate of #15668 as it references the existing Size field used to generate img tags and handling the registration of custom/default image sizes.

Indeed, thanks. Reopened that ticket.

comment:4 @SergeyBiryukov2 years ago

#21114 was marked as a duplicate.

comment:5 @ericlewis15 months ago

  • Focuses ui added
  • Keywords close added

Hi @dfcowell, thanks for your work here. I unfortunately disagree with adding this as a feature.

In my own web surfing, I appreciate links on images that go directly to the fullsize (canonical?) file. If authors linked to an intermediary filesize, I probably wouldn't even notice in the URL, and assume that was the full filesize.

WordPress also embraces a philosophy of Decisions, not Options, and that can be applied literally here: let's not clutter UIs with options that few users will use, and for many will confuse.

comment:6 @ericlewis15 months ago

  • Version changed from 3.6 to 3.5

comment:7 @helen15 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Understand the motivation behind the request and appreciate the ticket, but as far as core goes, agree with ericlewis's points.

Note: See TracTickets for help on using tickets.