WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 20 months ago

#24032 closed defect (bug) (duplicate)

An issue with the theme customize function and jQuery tabs

Reported by: splashingpixels.com Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Customize Keywords:
Focuses: Cc:

Description

WP 3.5.1 ( same happens in the 3.6 beta-1 )
No plugins installed ( vanilla WP )
TwentyTwelve Theme ( happens with TwentyThirteen as well )

So when you have or using jQuery Tabs in a page and you go to the theme customize page, the customizer panel will become sluggish and not very responsive when you hover your mouse over the accordion panel and if you look at the preview, the content is jumbled and also very sluggish. It seems something is executing in a loop over and over again making it sluggish but I did not see anything in the error console for some reason. Perhaps this is because it is on an iFrame.

Please note that the page in the frontend loads just fine with the jQuery Tabs and works normally. It is only when you use the backend theme customize page is where this issue starts.

I have tried this in both 3.5.1 and 3.6 beta-1 and same results.

Here are the steps to reproduce this.

In functions.php load up:

wp_enqueue_script( 'jquery-ui-core' );
wp_enqueue_script( 'jquery-ui-tabs' );

In the homepage (any page) put in:

<div class="test">
<ul>
<li><a href="#abc">abc</a></li>
<li><a href="#xyz">xyz</a></li>
</ul>
<div id="abc">
	some content here
</div>
<div id="xyz">
	some other content
</div>
</div>

In theme js, put in:

$('.test').tabs();

Then go to your homepage in the frontend to confirm the tabs are working and normal. Now go to the backend theme customize and you will see the issue I am trying to describe.

Change History (5)

comment:2 @splashingpixels.com2 years ago

I did a search prior to posting. Not sure why it didn't find that existing ticket. :)

comment:3 @SergeyBiryukov2 years ago

  • Component changed from Administration to Appearance

comment:4 @deltafactory20 months ago

This is a jQuery "bug"/known conflict with the <base> tag as used by the Customizer. See http://core.trac.wordpress.org/ticket/23225#comment:11 for a full description.

comment:5 @helen20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23225.

Note: See TracTickets for help on using tickets.