Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24038 closed defect (bug) (duplicate)

Revision diff colors aren't varied enough

Reported by: ethitter Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Revisions Keywords:
Focuses: Cc:


In 3.5, there were two colors for both additions and deletions: one for the background of a modified line, and another for individual changes with in a line. In beta, we've lost the second color for individual changes.

As a result, if a single word is added or removed, the entire line it appears in looks to be either inserted or deleted because the ins and del tags' background colors match that of the rest of the line.

Attached screenshots illustrate the issue.

Attachments (3)

with-separate-bg-color.png (72.0 KB) - added by ethitter 2 years ago.
with-single-bg-color.png (70.5 KB) - added by ethitter 2 years ago.
24038.patch (1014 bytes) - added by ethitter 2 years ago.
Restores colors used for individual changes in 3.5

Download all attachments as: .zip

Change History (8)

comment:1 @ocean902 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.6

@ethitter2 years ago

Restores colors used for individual changes in 3.5

comment:3 @ethitter2 years ago

At the very least, we should restore the background colors used in 3.5 for the ins and del elements. 24038.patch does that.

The accessibility group should weigh in on the possible use of patterns or other indicators to differentiate between the line and word changes.

comment:4 @bpetty2 years ago

Agreed, this should just go in now. I'm still not sure if anything is going to happen with #23810 before release (everyone seems pretty busy/backlogged with post formats).

comment:5 @ocean902 years ago

  • Keywords needs-patch removed
  • Milestone 3.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23810.

Note: See TracTickets for help on using tickets.