WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24041 closed defect (bug) (duplicate)

Slug meta box should be added as supported parameter for CPT and post_type_support

Reported by: wycks Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Posts, Post Types Keywords: 2nd-opinion
Focuses: Cc:

Description

When registering a CPT there is no parameter to remove the slug meta box.

Setting:

 'public' => false, 
  //Removes the permalink edit box but does not remove the slug meta box
 'rewrite' => false,
  //Also does not remove the slug meta box and still allows for editing the slug?

Possible solution:
Add a new supports parameter 'supports' => array('slug-box'), when registering a CPT

Furthermore it is confusing in conjunction with the edit permalink problem(related #18523 ).

Change History (3)

comment:1 @wycks2 years ago

  • Keywords reporter-feedback removed

comment:2 @helen2 years ago

Can we work on just removing that metabox entirely, as suggested in #18523?

comment:3 @nacin2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

The slug meta box is required to support permalink changes using the fancier UI near the title field. So, this is a duplicate of #18523.

Note: See TracTickets for help on using tickets.