WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#24062 closed defect (bug) (fixed)

Force gallery state for gallery post format

Reported by: lessbloat Owned by: markjaquith
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Post Formats Keywords: has-patch commit
Focuses: Cc:

Description

One of the items uncovered with the last round of usability tests was that users don't know that they are not adding a gallery.

When the gallery post format is selected, and the user clicks the "Add Media" button, we should take them to the gallery section of the media modal.

Attachments (3)

24062.diff (2.7 KB) - added by lessbloat 3 years ago.
24062.2.diff (2.7 KB) - added by wonderboymusic 3 years ago.
24062.3.diff (507 bytes) - added by adamsilverstein 3 years ago.
reintroduce if ( workflow ) check

Download all attachments as: .zip

Change History (13)

@lessbloat
3 years ago

#1 @lessbloat
3 years ago

24062.diff​ is a first attempt at making this happen. I'll include this patch in the next round of usability tests that I run.

#2 @wonderboymusic
3 years ago

Patch refreshed / cleaned up against trunk

#3 @markjaquith
3 years ago

  • Owner set to markjaquith
  • Resolution set to fixed
  • Status changed from new to closed

In 24087:

Force gallery state for gallery post format.

props lessbloat, wonderboymusic. fixes #24062.

#4 @markjaquith
3 years ago

In 24088:

Clean up gallery-mode toggling in post-formats.js and make sure it is set on first load.

see #24062

#5 follow-up: @programmin
3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Are you certain it is necessary to remove the

if ( workflow )
	return workflow

from the add function? Without this, current modifications that depend on getting a reference from the wp.media.editor.add function will break the uploading functionality, since other calls to add will create it again.

I have detailed the problem in this posting, if this can't be fixed I hope we can document a workaround.

http://lists.automattic.com/pipermail/wp-hackers/2013-May/046124.html

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

@adamsilverstein
3 years ago

reintroduce if ( workflow ) check

#6 in reply to: ↑ 5 @adamsilverstein
3 years ago

Replying to programmin:

Are you certain it is necessary to remove the

if ( workflow )
	return workflow

from the add function? Without this, current modifications that depend on getting a reference from the wp.media.editor.add function will break the uploading functionality, since other calls to add will create it again.

I have detailed the problem in this posting, if this can't be fixed I hope we can document a workaround.

http://lists.automattic.com/pipermail/wp-hackers/2013-May/046124.html

24062.3.diff​ reintroduces the if ( workflow ) check & return

#7 @ocean90
3 years ago

  • Keywords needs-testing removed
  • Milestone 3.6 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

#8 @SergeyBiryukov
3 years ago

  • Milestone set to 3.6
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version set to trunk

24062.3.diff still seems valid.

#9 @wonderboymusic
3 years ago

  • Keywords commit added

#10 @markjaquith
3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 24447:

Restore code that returns the existing media object if it already exists.

props programmin, adamsilverstein. fixes #24062

Note: See TracTickets for help on using tickets.