WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#2407 closed defect (bug) (duplicate)

"Ready for Publication" button needed for contributing authors

Reported by: skippy Owned by:
Milestone: Priority: normal
Severity: major Version: 2.0.1
Component: Administration Keywords: bg|needs-patch
Focuses: Cc:

Description

Contributing authors, who cannot directly publish items, need a way to communicate to editors that a draft is ready for publication.

There should exist on the Write screen a button that provides this facility. A "Ready for Publication" button should:

  • notify editors by email that a new post draft is ready for final review / publication
  • add the draft to a new list at the top of the Manage screen -- above the "Other's Drafts" section.

It might be nice to allow editors to accept OR reject the draft, along with a reason, but that bit might be better handled by a plugin.

Change History (5)

comment:1 markjaquith8 years ago

  • Summary changed from "Reay for Publication" button needed for contirbuting authors to "Ready for Publication" button needed for contirbuting authors

comment:2 skippy8 years ago

  • Summary changed from "Ready for Publication" button needed for contirbuting authors to "Ready for Publication" button needed for contributing authors

comment:3 skippy8 years ago

This is basically a duplicate of ticket #2238 : "Roles: Notification of posts to be published"

comment:4 matt7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

comment:5 Nazgul7 years ago

  • Milestone 2.1 deleted
Note: See TracTickets for help on using tickets.