WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 3 months ago

#24119 closed feature request (invalid)

A uniform approach to Plugins / Themes settings

Reported by: ryansatterfield Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Administration Keywords: ui-feedback
Focuses: Cc:

Description (last modified by DrewAPicture)

Yesterday in IRC (#WordPress), we had a conversation about rules that would help make plugins and themes easier to use, which in turn would make WordPress easier to use.

There isn't a rule or guideline whether a plugin should make a tab or link under settings or if it even has to do any of the above. We all agreed that all plugins should have a link under settings. If the plugin enhances a different part of the site, the settings page could just tell you where the plugin feature is located.

We also agreed that themes should put features like a static front page under customize like most already do, though I heard Responsive doesn't. I was told it puts static front page under settings. If it is a theme feature, then logically you should be able to at least find a link to where the features are under themes.

Implementing general rules for plugins and themes would make WordPress easier to use. Does anyone else agree?

Change History (13)

comment:1 ocean9012 months ago

Found this document in my bookmarks. Not sure who and where it started.

comment:2 follow-up: toscho12 months ago

  • Cc info@… added

Options pages should be where users expect it. A plugin that changes the appearance adds its menu to Appearance, and one for comments to Comments.

I think, asking plugin authors to create an overly long settings menu will not really help, and it would result in a bad UI. Nobody wants to tab through 20 items.

It should be easier to relocate settings pages. Akismet for example puts its comment page under Dashboard, not Comments – I would really like a simple way to fix that.

comment:3 follow-up: DrewAPicture12 months ago

Which IRC channel are you referring to, and who is "we"?

comment:4 in reply to: ↑ 3 ryansatterfield12 months ago

the freenode #wordpress channel. When I say we, I mean myself and a couple other people who were talking about this. I don't remember their handle names, but the conversation should be in the logs.
Replying to DrewAPicture:

Which IRC channel are you referring to, and who is "we"?

comment:5 in reply to: ↑ 2 ryansatterfield12 months ago

Replying to toscho:

Options pages should be where users expect it. A plugin that changes the appearance adds its menu to Appearance, and one for comments to Comments.

I think, asking plugin authors to create an overly long settings menu will not really help, and it would result in a bad UI. Nobody wants to tab through 20 items.

No, no one wants to tab through 20 tabs. The plugin page on settings could simply tell you where in your WordPress install it is located or be as detailed as the plugin creators wants.

Version 1, edited 12 months ago by ryansatterfield (previous) (next) (diff)

comment:6 DrewAPicture12 months ago

  • Description modified (diff)

comment:7 DrewAPicture12 months ago

  • Description modified (diff)

comment:8 SergeyBiryukov12 months ago

Sounds like a duplicate of #5833, #11577, and #18639.

This should probably be discussed on http://make.wordpress.org/ui/ first.

comment:9 SergeyBiryukov12 months ago

  • Component changed from General to Administration
  • Severity changed from trivial to normal

comment:10 follow-up: SergeyBiryukov12 months ago

There isn't a rule or guideline whether a plugin should make a tab or link under settings or if it even has to do any of the above.

Just found this:
http://codex.wordpress.org/Administration_Menus#Determining_Location_for_New_Menus

comment:11 in reply to: ↑ 10 ryansatterfield12 months ago

That's the problem. It is confusing for the average end-user, since there isn't a rule or guideline.
Replying to SergeyBiryukov:

There isn't a rule or guideline whether a plugin should make a tab or link under settings or if it even has to do any of the above.

Just found this:
http://codex.wordpress.org/Administration_Menus#Determining_Location_for_New_Menus

comment:13 helen3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is ill-suited for a Trac ticket, and is not something to implement in core. There are some efforts around plugin and theme dev handbooks, which is where guidelines like these would belong. I am myself not sure on the status of those, or what discussions if any have been had on this particular topic, but can ask around if you'd like.

Note: See TracTickets for help on using tickets.