WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#24135 closed defect (bug) (duplicate)

Twenty Thirteen doesn't show all supported post formats for default post format

Reported by: aniketpant Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

Just noticed that after activating Twenty Thirteen, all supported post formats are not available for selection in Settings > Writing > Default Post Format.

I first looked into wp-admin/options-writing.php, but it is only able to get only three post formats from the theme. So, I looked into the code for the theme and in twentythirteen/functions.php line 87

add_theme_support( 'structured-post-formats', array(
  'link', 'video'
) );

If the above code is removed, it seems to work. Not sure why structured-post-formats is changing post-formats.

Attachments (1)

24135.diff (508 bytes) - added by aniketpant 5 years ago.
Removes 'structured-post-formats` to fix bug

Download all attachments as: .zip

Change History (5)

@aniketpant
5 years ago

Removes 'structured-post-formats` to fix bug

#1 @aniketpant
5 years ago

  • Component changed from Themes to Bundled Theme

#2 @kovshenin
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24036.

#3 @aniketpant
5 years ago

I couldn't find that ticket. Thanks.

#4 in reply to: ↑ description @SergeyBiryukov
5 years ago

Replying to aniketpant:

Not sure why structured-post-formats is changing post-formats.

See the commit message in [23467] and the comment for 'post-formats' in add_theme_support().

Note: See TracTickets for help on using tickets.