WordPress.org

Make WordPress Core

Opened 23 months ago

Closed 8 weeks ago

#24181 closed defect (bug) (worksforme)

Dragging image in visual editor to new location results in text link

Reported by: rosso99 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.5
Component: TinyMCE Keywords:
Focuses: Cc:

Description

If there is an image in an existing post, dragging the image to a new paragraph / line or position in the post results in the image being replaced by the linked name of the file.

I've reproduced this on at least two different sites on WordPress.com. Attached are some screenshots.

  • Both drafts and published posts
  • Whether center, right, left -justified.

Attachments (4)

Screen Shot 2013-04-24 at 10.54.15 PM.png (43.4 KB) - added by rosso99 23 months ago.
After dragging - text link appears, not image.
Screen Shot 2013-04-24 at 10.54.24 PM.png (78.4 KB) - added by rosso99 23 months ago.
Before dragging - location & appearance of image are normal
Screen Shot 2013-04-25 at 3.06.11 PM.png (89.1 KB) - added by crushgear 23 months ago.
Before click-and-drag
Screen Shot 2013-04-25 at 3.06.21 PM.png (77.2 KB) - added by crushgear 23 months ago.
After click-and-drag

Download all attachments as: .zip

Change History (16)

@rosso9923 months ago

After dragging - text link appears, not image.

@rosso9923 months ago

Before dragging - location & appearance of image are normal

comment:1 @rosso9923 months ago

I have also replicated this error on a local install of trunk.

comment:2 follow-up: @SergeyBiryukov23 months ago

  • Component changed from Media to TinyMCE

comment:3 in reply to: ↑ 2 @rosso9923 months ago

Replying to SergeyBiryukov: Thanks - it wasn't clear to me where to stick this! :)

comment:4 follow-up: @SergeyBiryukov23 months ago

  • Keywords reporter-feedback added

Tested in trunk with Firefox 20, Chrome 26, IE 8, Opera 12. Could not reproduce so far.

  1. In which browser does it happen?
  2. Can you reproduce this on a clean install (with Twenty Twelve or Twenty Eleven theme activated and all plugins disabled)?
  3. Does it happen in 3.4 or 3.5 as well?

comment:5 follow-up: @rosso9923 months ago

Back with more testing. I'm on Mac OS 10.7.5.

Chrome:

  • It's happening on Chrome 26 (Version 26.0.1410.65).
  • The last test (non-WP.com) on trunk is on a clean install of trunk I just did today; no plugins active.
  • I restarted Chrome and was able to reproduce.
  • I rebooted my computer and was able to reproduce.
  • Was able to reproduce on a 3.5.1 install as well, in all cases above.

Other browsers:

  • Couldn't reproduce in Safari (6.0.4) nor Firefox (11) <--- sorry for old versions, I rarely use them.

comment:6 in reply to: ↑ 5 @rosso9923 months ago

I also disabled all Extensions on Chrome; was still able to reproduce.

comment:7 in reply to: ↑ 4 @crushgear23 months ago

Replying to SergeyBiryukov:

Tested in trunk with Firefox 20, Chrome 26, IE 8, Opera 12. Could not reproduce so far.

  1. In which browser does it happen?
  2. Can you reproduce this on a clean install (with Twenty Twelve or Twenty Eleven theme activated and all plugins disabled)?
  3. Does it happen in 3.4 or 3.5 as well?

I was able to replicate in a clean install of trunk in Chrome 26. Steps to replicate:

  1. Create a few paragraphs of text
  2. Insert a photo
  3. Click and drag the photo to another part of the text
  4. The photo disappears, turns into a text link

Added 2 screenshots.

@crushgear23 months ago

Before click-and-drag

@crushgear23 months ago

After click-and-drag

comment:8 @azaozz23 months ago

  • Cc spocke added

Looks like new Chrome/Mac bug. Doesn't happen in Chrome/Win. Can reproduce even on the TinyMCE 4.0 demo page: http://www.tinymce.com/tryit/basic.php. The link that replaces the image even has some "leaked" inline css (a long standing WebKit bug).

comment:9 @SergeyBiryukov23 months ago

  • Keywords reporter-feedback removed
  • Version changed from trunk to 3.5

comment:10 @SergeyBiryukov23 months ago

Confirmed with Chrome 26 in Mac OS X.

comment:11 @standardbanter23 months ago

  • Cc jason@… added

comment:12 @iseulde8 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Tried this in Chrome on a mac and I can't reproduce. Same for the TinyMCE demo. In the meantime we upgraded and updated TinyMCE a few times and Chrome has been updated a few times.

I'm going to go ahead an close this as the last report of this was almost 2 years ago. If this is still an issue, please don't hesitate to reopen. Clear steps to reproduce the issue consistently are appreciated.

Note: See TracTickets for help on using tickets.