Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#24195 closed defect (bug) (invalid)

WordPress clean install is not fully PHP 5.3 compatible

Reported by: klihelp's profile klihelp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Warnings/Notices Keywords:
Focuses: Cc:

Description

The latest WordPress beta (version 3.6-beta1-24067) have at least two for PHP 5.2 warnings.
I had a fresh install, no plugins, and theme had a front-page.php to echo only a word for a white test page.

This warning is for Eukhost.com hosting:

PHP Warning:  PHP Startup: Suhosin Extension does not officially support PHP 5.2 and below anymore, because it is discontinued. Use it at your own risk. in Unknown on line 0

Thanks WordPress:)

Change History (3)

#1 @knutsp
11 years ago

  • Component changed from Performance to Warnings/Notices
  • Keywords close added

A Google search tells me this is server configuration related (latest Suhosin extension not supporting PHP 5.2). I can't see this as a WordPress problem.

#2 @dd32
11 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Most definitely a PHP configuration issue, and not a WordPress issue.

Contact your hosting provider and get them to upgrade your version of PHP to something recent, I'm pretty sure that error message is output before WordPress has even loaded, so there's little we can do to hide that type of notice.

#3 @knutsp
11 years ago

  • Keywords close removed
Note: See TracTickets for help on using tickets.