WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#24206 closed enhancement (duplicate)

Garbage collection for transients stored in the options table

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Cache API Keywords:
Focuses: Cc:

Description

When there's no persistent object cache in place, WordPress uses the options table to store transients. We should introduce garbage collection to avoid stale data sitting around indefinitely.

This should be fairly straight forward to implement. A daily cron schedule would fetch all options with a key that begin with _transient_timeout_ and a value that's less than the current time, then clear all the matching transients.

Any objections? I'll patch it up if not.

Change History (3)

comment:1 johnbillion12 months ago

Little bit of background discussion on Mark Jaquith's blog: http://markjaquith.wordpress.com/2013/04/26/fragment-caching-in-wordpress/

comment:2 SergeyBiryukov12 months ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed

Duplicate of #20316.

comment:3 SergeyBiryukov12 months ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.