WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24218 closed defect (bug) (fixed)

Post Formats UI prevents switching back to the starting format

Reported by: georgeclaghorn Owned by:
Milestone: 3.6 Priority: high
Severity: normal Version: 3.6
Component: Post Formats Keywords: has-patch
Focuses: Cc:

Description

Steps to reproduce:

  1. Go to the Add New Post page. (wp-admin/post-new.php)
  2. Change the Post Format from Standard to anything else.
  3. Try to change back to the Post Format back to Standard.

Nothing happens. The UI refuses to change back to the Standard format. I'm using the 3.6 beta release of WordPress and the latest stable version of Google Chrome.

If you preset a different format for the Add New Post page (via the format GET parameter), and attempt to switch away from and back to the starting format, the results are similar.

Attachments (1)

24218.patch (394 bytes) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 @SergeyBiryukov2 years ago

  • Keywords reporter-feedback added

Could not reproduce neither in Chrome 26 nor in Firefox 20.

Does it still happen on a clean install (with Twenty Thirteen theme activated and all plugins disabled)?

comment:2 @georgeclaghorn2 years ago

  • Keywords reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

Hmm, you're right. Can't reproduce on a clean install.

comment:3 @SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted

comment:4 @SergeyBiryukov2 years ago

Would be nice to find the culprit and see what exactly causes the UI breakage.

comment:5 @georgeclaghorn2 years ago

This happens whenever I have the visual editor disabled. I'll look at the JS and see if I can find exactly where it fails.

comment:6 @SergeyBiryukov2 years ago

  • Milestone set to 3.6
  • Priority changed from normal to high
  • Resolution invalid deleted
  • Status changed from closed to reopened

Confirmed on a clean install with Visual editor disabled.

Error: ReferenceError: tinymce is not defined
Source File: http://trunk.wordpress/wp-admin/js/post-formats.js?ver=3.6-beta1-24113
Line: 124

@SergeyBiryukov2 years ago

comment:7 @SergeyBiryukov2 years ago

  • Keywords has-patch added

comment:8 @SergeyBiryukov2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.