WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#24220 closed defect (bug) (duplicate)

Administering wih SSL and uploading images makes image links HTTPS

Reported by: ccolotti Owned by:
Milestone: Priority: normal
Severity: major Version: 3.3
Component: Media Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

I am noticing this issue in 3.3 that all uploaded attachments are listed in the library using HTTPS in the location when administerng over SSL. I tried the patch.2 listed and it does not seem to change anything. Previously this was never an issue, but now all my images are getting added as HTTPS when I do not want them to be. I end up searching the DB for " ​https://" and replacing with HTTP after every post.
Will this ever get resolved back to normal so SSL admin can be used without having all attachments over SSL? I only have SSL for login and admin.

I first reported this issue 16 months ago and it is STILL the same. The original bug is here: #19722

The bottom line is adding media files in a multisite with HTTPS administration makes all the image files linked as HTTPS. I have an SSL robots.txt file to prevent indexing of HTTPS pages, but these should not be served up over SSL just becuase we are administering pages with SSL. The images should always be uploaded and address as NON SSL.

16 months to find out after re-enabling HTTPS admin that this is still an issue.

Change History (8)

comment:1 ccolotti12 months ago

It seems it is still based on this old ticket: #15928

Can we PLEASE get this fixed!

Last edited 12 months ago by SergeyBiryukov (previous) (diff)

comment:2 SergeyBiryukov12 months ago

  • Description modified (diff)

comment:3 SergeyBiryukov12 months ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed
  • Version changed from 3.5.1 to 3.3

Duplicate of #19722 and #15928.

comment:4 SergeyBiryukov12 months ago

  • Resolution set to duplicate

comment:5 ccolotti12 months ago

I am seeing this in 3.5.1 not 3.3, so by this point it may be a different issue.

comment:6 SergeyBiryukov12 months ago

Well, the substantial part of this ticket's description is an exact copy of the description in #19722, which makes it the same issue.

If you have more details, you should add them to your original ticket.

comment:7 follow-up: ccolotti12 months ago

Specifically for 3.5.1 You can have admin over SSL with a site over HTTP. In this situation, WordPress currently incorrectly inserts a images into your post content using the HTTPS scheme instead of HTTP. This has never been fixed SINCE I first reported it in 3.3

comment:8 in reply to: ↑ 7 SergeyBiryukov12 months ago

Replying to ccolotti:

This has never been fixed SINCE I first reported it in 3.3

Yes, that's why your original ticket is still open. Version field indicates when the bug was initially introduced/reported, not the current version.

Note: See TracTickets for help on using tickets.