WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#24271 closed enhancement (duplicate)

Facilitate PHP versions in themes and plugins

Reported by: ryanve Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords:
Focuses: Cc:

Description

I want to propose a future-proof mechanism for safely allowing PHP 5.3+ in themes and plugins:

/**
 * Theme Name: example
 * Minimum PHP version: 5.3.0
 * ...
 */

Minimum version info could be used on the theme installation page to prevent 5.2- users from installing 5.3+ themes. The "Activate" link could be subdued or replaced with a link to inform the user that the theme needs a higher PHP version. Unspecified minimums would default to the WP requirement.

I initiated this discussion in the theme-reviewers list. Primary feedback there was to prevent breakage via graceful degradation or otherwise. The mechanism above is viable. Interim solutions are possible but less seamless.

Encouraging 5.3+ helps expedite user transition to 5.3+ and thus helps the core too.

Change History (4)

comment:1 markoheijnen12 months ago

See #23880. To me this is something bad since it doesn't help a lot for people upgrading to 5.3 or higher. They probably go find another theme/plugin that does the same job.

comment:2 SergeyBiryukov12 months ago

  • Keywords close added

Sounds like a duplicate of #23880 and #12260.

comment:3 ocean9012 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Status changed from new to closed

comment:4 ocean9012 months ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.