WordPress.org

Make WordPress Core

Opened 23 months ago

Closed 23 months ago

Last modified 23 months ago

#24275 closed defect (bug) (wontfix)

Twenty Thirteen: Too thin font in sidebar in Safari on a non-Retina display

Reported by: RDall Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords: needs-patch needs-testing
Focuses: Cc:

Description

When a video post is on the page in Safari 6.0.4 the sidebar text is effected. This is not easily seen in twenty thirteen because of the beige and white. But it is easily reproducible through the following steps.

Change the background color of the widget to black. (hear me out) and then give the widget title the colour white. I am doing this so you can more easily see what is occurring.

I then went to a page with a video on it and saw an error in the sidebar:
http://cl.ly/image/2J0B2j0X2I1I/o

Then I went to a page without video and the sidebar loaded properly.
http://cl.ly/image/0P111l0v0p1a

The reason I couldn't get the issue to replicate on the front page of Theme Buster but I could on my own sandbox site is because I had a embeded video on my front page and the themebuster does not. Which caused great confusion.

I was able to see this issue on four separate OSX machines. Two of which I owned and two of which were at a local Apple dealer.

But so far I have been the only one to see this error… but on four different computers.

Attachments (2)

Screen Shot 2013-05-07 at 12.48.29 AM.png (1.6 MB) - added by johnjamesjacoby 23 months ago.
24275.png (36.6 KB) - added by SergeyBiryukov 23 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 @RDall23 months ago

I spoke with Lance about this earlier when I was still trying to hunt this one down… Here is our chat http://cl.ly/image/3C3x0M3u0t3k

comment:2 @johnjamesjacoby23 months ago

Probably related to the sidebar opacity, and color dithering on non-retina displays.

Not able to duplicate this in Safari 6.0.5 on Retina.

comment:3 @RDall23 months ago

I just don't get it… I can get this to reproduce on brand new 27 iMac's with a clean install running safari. The salesman saw the same thing… Then I come home jump on IRC and JJJ can't replicate it… Also Christine Rondeau can't see it either… 

comment:4 @lancewillett23 months ago

Would be good if someone else could try to repeat before we spend more time trying to figure out the cause.

comment:5 @RDall23 months ago

I had 10 minutes to kill and was near a another apple dealer different to the previous one. I viewed both my sandbox and themebusters on a 15" Macbook pro with Safari and a 13" Air and could not see the formating bug in question.

The only other think I can think of is that it's something to do with retina display which 27" iMac don't have and / or the safari version.

Regardless as mentioned previously if it can't be replicated else where it is quite the fringe case and not a problem that can be can fixed on our end.

comment:6 @RDall23 months ago

  • Resolution set to invalid
  • Status changed from new to closed

@SergeyBiryukov23 months ago

comment:7 @SergeyBiryukov23 months ago

Reproduced on non-Retina display (Safari 4.0.3, Mac OS X 10.6.2): 24275.png.

Embedded video was irrelevant in my case, I didn't have it on the page.

comment:8 @SergeyBiryukov23 months ago

  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to wontfix
  • Summary changed from Twenty Thirteen: Emdeded Video causes sidebar style in Safari to Twenty Thirteen: Too thin font in sidebar in Safari on a non-Retina display

Feel free to reopen with a patch if you find a solution.

Note: See TracTickets for help on using tickets.