WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#24278 closed defect (bug) (duplicate)

Quotes Invalid/Inconsistent on Attributes within general-template.php

Reported by: sterlo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Formatting Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

The file I'm speaking of:
https://github.com/WordPress/WordPress/blob/master/wp-includes/general-template.php

Story: I was trying to take paginate_links() and customize the markup by running regular expressions and pulling out the classes and values and such. The regular expressions weren't working...because the markup was incorrectly and inconsistently using single quotes for attributes instead of double quotes.

I saw that, looked throughout the file, found more offenses.

Here's a list:

  • get_archives_link()
  • wp_no_robots()
  • paginate_links()
  • wp_admin_css()

and I'm not sure, but it also looks like __checked_selected_helper() is offending.

I'll be attaching patches for this.

Attachments (4)

get_archives_link.patch (1.3 KB) - added by sterlo 11 months ago.
get_archives_link() fix
wp_no_robots.patch (585 bytes) - added by sterlo 11 months ago.
wp_no_robots() fix
paginate_links.patch (1.7 KB) - added by sterlo 11 months ago.
paginate_links() fix
wp_admin_css.patch (1.1 KB) - added by sterlo 11 months ago.
wp_admin_css() fix

Download all attachments as: .zip

Change History (9)

sterlo11 months ago

get_archives_link() fix

sterlo11 months ago

wp_no_robots() fix

sterlo11 months ago

paginate_links() fix

sterlo11 months ago

wp_admin_css() fix

comment:1 ocean9011 months ago

I don't see a problem with this inconsistency, both are valid, even none are valid.

Related: #20450

comment:2 SergeyBiryukov11 months ago

  • Description modified (diff)

comment:3 SergeyBiryukov11 months ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed

Duplicate of #23305.

comment:4 SergeyBiryukov11 months ago

  • Resolution set to duplicate

comment:5 sterlo11 months ago

Awww that makes me sad.

Note: See TracTickets for help on using tickets.