WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#24279 closed enhancement (duplicate)

wp_signups table does not have a primary key

Reported by: econnell Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Database Keywords:
Focuses: Cc:
PR Number:

Description

There was an old bug from 7 years ago on the WPMU Trac that was marked as "wontfix" for this, however, this is the only table in the WP database schema that is missing a primary key.

Using Percona XtraDB Cluster, a primary key is needed on all tables in order to perform DELETE statements across the cluster as described here: http://www.percona.com/doc/percona-xtradb-cluster/limitation.html. It can just be an auto increment "id" column if duplicate entries are needed in this table.

Change History (2)

#1 @nacin
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

Let's mark this as a duplicate of #15004 so we can go about setting a primary key and an index in one shot.

#2 @SergeyBiryukov
7 years ago

  • Resolution changed from fixed to duplicate
Note: See TracTickets for help on using tickets.