WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24316 closed defect (bug) (invalid)

Post Format Selector Icons Display One-per-line in IE7

Reported by: celloexpressions Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Post Formats Keywords: has-patch
Focuses: Cc:

Description

IE 7 doesn't like max-width or min-width. By explicitly specifying the width property, the icons will display as intended instead of... horrifically.

Attachments (4)

post formats ie7.png (34.7 KB) - added by celloexpressions 2 years ago.
Current Post Formats Selector UI in IE 7
fix-post-format-selector-ie7.diff (369 bytes) - added by celloexpressions 2 years ago.
Specify the width property for the selector links, resolving the layout issue for IE7.
24316.1.diff (1.2 KB) - added by celloexpressions 2 years ago.
Use width instead of max-width, opacity for ie7/8, minor coding standards fixes
24316.2.diff (1.4 KB) - added by celloexpressions 2 years ago.
Only apply width property to ie7, fix opacity for ie7 and ie8

Download all attachments as: .zip

Change History (10)

@celloexpressions2 years ago

Current Post Formats Selector UI in IE 7

@celloexpressions2 years ago

Specify the width property for the selector links, resolving the layout issue for IE7.

comment:1 @SergeyBiryukov2 years ago

  • Milestone changed from Awaiting Review to 3.6

@celloexpressions2 years ago

Use width instead of max-width, opacity for ie7/8, minor coding standards fixes

comment:2 follow-up: @celloexpressions2 years ago

Looking through it more, I see no reason to use min-width instead of width, so we should just use width in the main stylesheet and ie7 will be corrected without further polluting ie.css.

I noticed a couple of minor coding standards things, so I think that the min-width may have just been leftover from something in the rush to put together the updated UI. New patch also adds the opacity filters for IE7&8 to ie.css, since that's an important part of the UI and an easy fix.

comment:3 in reply to: ↑ 2 @ocean902 years ago

Replying to celloexpressions:

Looking through it more, I see no reason to use min-width instead of width, so we should just use width in the main stylesheet

Think of longer translation for the texts. If it's fixed it will change the height for longer strings or even worse overflow the box.

@celloexpressions2 years ago

Only apply width property to ie7, fix opacity for ie7 and ie8

comment:4 @celloexpressions2 years ago

Ah, I knew it was something to do with the text. I don't think there's any way around using width for IE7, but it's IE7 and at least it will look better than one-format-per-line. New patch also fixes opacity in IE8, didn't realize those have to go in the main stylesheet (that is where they go, right?).

comment:5 @SergeyBiryukov2 years ago

Yes, IE8 styles go in the main stylesheet.

comment:6 @ocean902 years ago

  • Milestone 3.6 deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.