WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 11 months ago

#24338 closed defect (bug) (duplicate)

Feature image not stored as an attachment when selecting existing image from Media Library

Reported by: whodeee Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

Selecting a Featured Image for a post that is already in the Media Library does not store it as an attachment, however when uploading an image using the Featured image panel, then it does store it as an attachment.

The differences are also that the image gets the post name in the "Uploaded to" column in the Media Library, however when selecting one that already exists, this column does not get the post name filled in. I realize that it is not filled in as it wasn't "uploaded to" that post, but there may be some correlation between that and the attachment issue above.

Change History (4)

comment:2 in reply to: ↑ description ; follow-up: @ericlewis11 months ago

Replying to whodeee:

Selecting a Featured Image for a post that is already in the Media Library does not store it as an attachment

What do you mean exactly? Where do you expect to see it "stored as an attachment?"

comment:3 in reply to: ↑ 2 @DrewAPicture11 months ago

  • Keywords reporter-feedback added

Replying to ericlewis:

Replying to whodeee:

Selecting a Featured Image for a post that is already in the Media Library does not store it as an attachment

What do you mean exactly? Where do you expect to see it "stored as an attachment?"

I think @whodeee is suggesting that the "uploaded to this post" filter should include the featured image if set (even if it isn't actually "attached" to the post.

Kind of brings up an interesting discussion point, as featured images are in a way "attached" by having their ID stored in the post meta, though are not treated as attached.

comment:4 @SergeyBiryukov11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15807.

Note: See TracTickets for help on using tickets.