WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#24340 closed defect (bug) (fixed)

Single mode comparison broken on oldest revision since RTL commit

Reported by: a.hoereth Owned by: ocean90
Milestone: 3.6 Priority: normal
Severity: major Version: 3.6
Component: Revisions Keywords: needs-patch
Focuses: Cc:

Description

When viewing the oldest revision in single mode you should see the diff {empty against initial revision}. Instead the diff is {empty against newest revision}. See Screenshots

How to reproduce:
You need a post with 3+ revisions. In normal mode view the oldest (most left) revision and compare the diff with what is being displayed when you move the slider one tick to the right.

Attachments (4)

24340.png (10.9 KB) - added by a.hoereth 6 years ago.
24340b.png (8.7 KB) - added by a.hoereth 6 years ago.
24340c.png (8.3 KB) - added by a.hoereth 6 years ago.
24340.diff (711 bytes) - added by adamsilverstein 6 years ago.
correct reversal check for l-r comparison

Download all attachments as: .zip

Change History (16)

@a.hoereth
6 years ago

@a.hoereth
6 years ago

@a.hoereth
6 years ago

#1 @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to 3.6

#2 follow-up: @ocean90
6 years ago

  • Cc adamsilverstein added

Thanks for the ticket. Mentioned it first on IRC chat, but was the only one. So there is definitely something going wrong here.

#3 in reply to: ↑ 2 @adamsilverstein
6 years ago

Replying to ocean90:

Thanks for the ticket. Mentioned it first on IRC chat, but was the only one. So there is definitely something going wrong here.

i didn't see issue before but maybe didn't understand. will look again.

#4 follow-up: @adamsilverstein
6 years ago

i still can't reproduce, maybe i am missing something? are you certain you are running current trunk? are you doing something different than what i am doing?

here is a screencast of my test, my 1st revision looks fine:

http://f.cl.ly/items/1k1a1J361x023C1h2u2Z/post-test3%20-%20Broadband.m4v

RTL mode test, also looks fine

http://f.cl.ly/items/0T2c2k0C0w471p0B3i33/rtl-test%20-%20Broadband.m4v

#5 @adamsilverstein
6 years ago

  • Keywords 2nd-opinion added

#6 @adamsilverstein
6 years ago

  • Keywords dev-feedback added

#7 in reply to: ↑ 4 ; follow-ups: @a.hoereth
6 years ago

Replying to adamsilverstein:

i still can't reproduce, maybe i am missing something? are you certain you are running current trunk? are you doing something different than what i am doing?

here is a screencast of my test, my 1st revision looks fine:

http://f.cl.ly/items/1k1a1J361x023C1h2u2Z/post-test3%20-%20Broadband.m4v

RTL mode test, also looks fine

http://f.cl.ly/items/0T2c2k0C0w471p0B3i33/rtl-test%20-%20Broadband.m4v

Try reproducing it with "save draft" instead of "publish": http://www.screenr.com/cSI7
Maybe you can update the original ticket description.

#8 @ocean90
6 years ago

  • Keywords 2nd-opinion dev-feedback removed

#9 in reply to: ↑ 7 @adamsilverstein
6 years ago

Replying to a.hoereth:

Replying to adamsilverstein:

i still can't reproduce, maybe i am missing something? are you certain you are running current trunk? are you doing something different than what i am doing?

here is a screencast of my test, my 1st revision looks fine:

http://f.cl.ly/items/1k1a1J361x023C1h2u2Z/post-test3%20-%20Broadband.m4v

RTL mode test, also looks fine

http://f.cl.ly/items/0T2c2k0C0w471p0B3i33/rtl-test%20-%20Broadband.m4v

Try reproducing it with "save draft" instead of "publish": http://www.screenr.com/cSI7
Maybe you can update the original ticket description.

aha! thanks for clarifying! will look at this again.

@adamsilverstein
6 years ago

correct reversal check for l-r comparison

#10 @adamsilverstein
6 years ago

24340.diff​:

  • corrects check for ensuring comparison always from newer->older revision, reversing special case 1st revision was corrupting later login design to compare to 'blank' initial revision (for single handle mode)

#11 in reply to: ↑ 7 @adamsilverstein
6 years ago

Replying to a.hoereth:

Replying to adamsilverstein:

i still can't reproduce, maybe i am missing something? are you certain you are running current trunk? are you doing something different than what i am doing?

here is a screencast of my test, my 1st revision looks fine:

http://f.cl.ly/items/1k1a1J361x023C1h2u2Z/post-test3%20-%20Broadband.m4v

RTL mode test, also looks fine

http://f.cl.ly/items/0T2c2k0C0w471p0B3i33/rtl-test%20-%20Broadband.m4v

Try reproducing it with "save draft" instead of "publish": http://www.screenr.com/cSI7
Maybe you can update the original ticket description.

thanks for identifying that bug - 24340.diff​ fixes this issue, please review

#12 @ocean90
6 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 24263:

Revisions: Correct check for ensuring comparison always from newer to older revision. props adamsilverstein. fixes #24340.

Note: See TracTickets for help on using tickets.