WordPress.org

Make WordPress Core

#24344 closed defect (bug) (fixed)

More Tag not visible in the Visual Editor

Reported by: esmi Owned by:
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: TinyMCE Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

When clicking on the "Insert More Tag" button in the WYSIWYG editor, the more tag line is not visible. The <!--more--> tag has been added & can be seen in the Text Editor but not in the Visual pane.

Both:

img.mceWPmore {
    background: url("img/more_bug.gif") no-repeat scroll right top transparent;
}

and:

img.mceWPnextpage, img.mceWPmore {
    -moz-border-bottom-colors: none;
    -moz-border-left-colors: none;
    -moz-border-right-colors: none;
    -moz-border-top-colors: none;
    border-color: #CCCCCC -moz-use-text-color -moz-use-text-color;
    border-image: none;
    border-right: 0 none;
    border-style: dotted none none;
    border-width: 1px 0 0;
    display: block;
    height: 12px;
    margin: 15px auto 0;
    width: 95%;
}

seem to be missing from content.css when checked using Firebug.

Using 3.6-beta3-24260 (lasest nightly 15/05/13) & Twenty Twelve. The issue has also been confirmed using other themes.

Change History (9)

comment:1 SergeyBiryukov11 months ago

  • Description modified (diff)

comment:2 SergeyBiryukov11 months ago

  • Milestone changed from Awaiting Review to 3.6

The classes aren't missing, they were renamed in [24215].

Confirmed with SCRIPT_DEBUG off. Looks like the bumpbot didn't update $tinymce_version, so the compressed file (wp-tinymce.js.gz) is stale. The last update was 3 weeks ago in [24113].

Last edited 11 months ago by SergeyBiryukov (previous) (diff)

comment:3 azaozz11 months ago

The classes were renamed attempting to fix #24177. Still need a confirmation that actually fixes it in all cases (it's a weird bug in Chrome not applying the css inside the editor).

However that shouldn't break the functionality. After bumpbot runs the styling would fall back to the default editor styles.

comment:4 kovshenin11 months ago

  • Keywords close added

Looks like this is fixed now.

comment:5 SergeyBiryukov11 months ago

  • Keywords close removed

$tinymce_version is still the same in trunk, and I can still reproduce with SCRIPT_DEBUG off.

comment:6 kovshenin11 months ago

Sergey: ah, missed the script debug part, thanks for clarifying!

comment:7 SergeyBiryukov11 months ago

#24379 was marked as a duplicate.

comment:8 coreygilmore10 months ago

  • Cc corey@… added

comment:9 SergeyBiryukov10 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [24485].

Note: See TracTickets for help on using tickets.