WordPress.org

Make WordPress Core

Opened 23 months ago

Closed 22 months ago

Last modified 21 months ago

#24360 closed defect (bug) (invalid)

Unable to use supports=>post-formats without support for thumbnail

Reported by: zabatonni Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Post Formats Keywords: has-patch reporter-feedback
Focuses: Cc:

Description

in custom post type you cant choose post-formats capability whithout using thumbnail. Post formats UI shows but after changing format it redirects me to normal posts not the custom one.

Attachments (1)

24360.diff (2.3 KB) - added by kovshenin 23 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 @SergeyBiryukov23 months ago

  • Milestone changed from Awaiting Review to 3.6
  • Version set to trunk

@kovshenin23 months ago

comment:3 @kovshenin23 months ago

  • Keywords has-patch added

24360.diff should do it.

comment:4 @SergeyBiryukov22 months ago

24360.diff fixes the issue reported on the forums (redirect to Posts screen when switching post formats with JS disabled).

Could not reproduce the original issue. Does it still happen on a clean install with JavaScript enabled?

My steps:

  1. Created a new post type with the second example from Codex.
  2. Added 'post-formats' to 'supports' argument, removed 'thumbnail':
    'supports' => array( 'title', 'editor', 'author', 'excerpt', 'comments', 'post-formats' )
    
  3. Created a new Book. Verified that switching post formats works correctly.
Last edited 21 months ago by SergeyBiryukov (previous) (diff)

comment:5 @SergeyBiryukov22 months ago

  • Keywords reporter-feedback added

comment:6 @SergeyBiryukov22 months ago

In 24373:

Fix switching post formats when JavaScript is disabled. props kovshenin. see #24360.

comment:7 @wonderboymusic22 months ago

  • Milestone 3.6 deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.