WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 3 months ago

Last modified 3 months ago

#24369 closed defect (bug) (worksforme)

"Open link in a new window/tab" shows the wrong information

Reported by: hubertnguyen Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Editor Keywords:
Focuses: Cc:

Description

I noticed that the "Open link in a new window/tab" checkbox in Wordpress' editor sometime shows the wrong information. I can get this consistently by:

1/ writing a post in word, including links inserted in Word

2/ copy the text to WP's editor

3/ links will be converted from Word in clean HTML and will open in the same window by default

4/ select the first link and open "Insert/Edit Link" by clicking on the Link button. The first time, the box will be unchecked. That's correct.

5/ change that first link to "Open link in a new window/tab". click on Update

6/ go to the next link and open "Insert/Edit Link" again. Oh no it shows the "Open link in a new window/tab" checked while the HTML code shows that it is NOT targeted to "_blank".

Example: WP's editor says that this will open in aa new window: http://screencast.com/t/rxR6oeEjL

Bur the HTML is clear: it's not targeted to "_blank": http://screencast.com/t/xDBnYsh9Z

Thank you,

Change History (1)

comment:1 azaozz3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Cannot reproduce. The Insert/Edit Link dialog "remembers" that checkbox, so if you've clicked it when inserting or editing a link, it will be still on when inserting another link. However if you're editing a link, it shows the proper state.

Feel free to reopen if this is still an issue.

Last edited 3 months ago by azaozz (previous) (diff)
Note: See TracTickets for help on using tickets.