WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#24370 closed feature request (duplicate)

Get the "Set Featured Image" Back

Reported by: hubertnguyen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

Since 3.4, the workflow of "Set Featured Image" has been significantly slower and less efficient. Up to 3.3, one could do:

1/ upload/find image
2/ click on set featured image
3/ click on insert image in post
dialog closes. done.

Now, the same thing requires

1/ upload/find image
2/ insert in post. dialog closes
3/ click on set featured image. dialog open
4/ potentially search again
5/ click on set featured image
dialog closes. done.

Since most blog posts only feature one image, it would make sense that we could do both "set featured" and "insert in post" while being in the insert media dialog.

My writers have been pointing this out since we switch to 3.4, so we hope that this feedback will receive a positive attention.

Thank you!
A recently uploaded image would appear at the top when we open the Insert media dialog, but if we need to search the image again, it does hamper the workflow quite a bit.

Change History (2)

#1 @aniketpant
7 years ago

I am not sure why this is happening with you. I can easily set a featured image in 3 clicks. All I need to do is click on the "Set featured image" button, then select an image from my library and click on the "Set featured image" button. That is it.

#2 @SergeyBiryukov
7 years ago

  • Keywords reporter-feedback added; ui-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Since 3.4, the workflow of "Set Featured Image" has been significantly slower and less efficient. Up to 3.3, one could do...

You mean the changes in 3.5, right? There were no changes in media workflow between 3.3 and 3.4.

This is a duplicate of #22970 and #22963.

Note: See TracTickets for help on using tickets.