WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 22 months ago

#24373 closed defect (bug) (fixed)

WordPress Importer - Strict Standards compatibility

Reported by: kpdesign Owned by: rmccue
Milestone: WordPress.org Priority: normal
Severity: normal Version: 3.6
Component: Import Keywords: dev-feedback
Focuses: Cc:

Description

I am seeing the following errors on wp-admin/import.php, running 3.6-beta3-24300 and PHP 5.4.7, in my single and multisite test installs:

Strict Standards: Redefining already defined constructor for class WXR_Parser_Regex in xxxxx\wp-content\plugins\wordpress-importer\parsers.php on line 408

Strict Standards: Declaration of WP_Import::bump_request_timeout() should be compatible with WP_Importer::bump_request_timeout($val) in xxxxx\wp-content\plugins\wordpress-importer\wordpress-importer.php on line 38

Attachments (2)

24373.diff (927 bytes) - added by iandunn 5 years ago.
wp-import.diff (876 bytes) - added by jdgrimes 3 years ago.
Fix deprecated warnings for WP_Import in PHP7

Download all attachments as: .zip

Change History (60)

#1 @SergeyBiryukov
5 years ago

  • Milestone changed from Awaiting Review to WordPress.org

#2 @iandunn
5 years ago

  • Cc ian.dunn@… added

I ran across this today too. I think it's basically the same thing as #20801. Should be an easy fix; I'll see if I can find some time over the weekend to patch it.

@iandunn
5 years ago

#4 @iandunn
5 years ago

Easy peasy. The only changes were in the plugin itself; nothing in Core had to change.

#5 @SergeyBiryukov
5 years ago

  • Keywords has-patch commit added

#6 follow-up: @nacin
5 years ago

Fixed in http://plugins.trac.wordpress.org/changeset/718670/wordpress-importer/. Committed to trunk only, it'll go out with a subsequent release.

#7 follow-up: @nacin
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

#8 @ocean90
4 years ago

#26729 was marked as a duplicate.

#9 in reply to: ↑ 6 @ocean90
4 years ago

Replying to nacin:

it'll go out with a subsequent release.

Any new plans for this?

#10 follow-up: @styledev
4 years ago

  • Keywords dev-feedback added

Any idea when this will actually get added into the plugin hosted on Wordpress.org? The last update was Jan. 14th, 2014 and did not include this patch...

#11 follow-up: @SergeyBiryukov
4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Let's keep the ticket open as a reminder.

#12 in reply to: ↑ 10 @iandunn
4 years ago

Replying to styledev:

Any idea when this will actually get added into the plugin hosted on Wordpress.org? The last update was Jan. 14th, 2014 and did not include this patch...

r838596-plugins wasn't actually a new release, it just updated the compatibility header from 3.6 to 3.8.

#13 @aubreypwd
4 years ago

+1 still seeing this

This ticket was mentioned in IRC in #wordpress-dev by aubreypwd. View the logs.


4 years ago

#15 @IntricatePixels
4 years ago

+1 also seeing this error:

Strict Standards: Declaration of WP_Import::bump_request_timeout() should be compatible with WP_Importer::bump_request_timeout($val) in /Users/my-local-path/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 38

#16 @lovememore
4 years ago

+1 seeing this error too. (WordPress 3.8.1)

#17 @cristiano.zanca
4 years ago

+1 (WordPress 3.9.1) seeing same error while importing from theme-unit-test-data.xml, in my xubuntu laptop with apache2 & nginx, SOLVED with kpdesign solution found on top the of this page:

#################

wordpress-importer.php line 1110 before function bump_request_timeout() { line 1110 after function bump_request_timeout( $val ) {

#################

Error was

( ! ) Strict standards: Declaration of WP_Import::bump_request_timeout() should be compatible with WP_Importer::bump_request_timeout($val) in /var/www/wp/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 38 Call Stack

Last edited 4 years ago by cristiano.zanca (previous) (diff)

#18 follow-up: @austinpray
4 years ago

Still seeing this. Installed from the wordpress interface on latest wordpress.

#19 in reply to: ↑ 18 @iandunn
4 years ago

Replying to austinpray:

Still seeing this. Installed from the wordpress interface on latest wordpress.

The fix was committed to the plugin's development branch, so you won't actually see it until a new version of the plugin is released.

#20 in reply to: ↑ 7 ; follow-up: @unleashyourgeekinc
4 years ago

  • Severity changed from normal to blocker

Replying to nacin: Fixed????? This is a show stopper. We are unable to do any imports for any of 100 sites from this. Is there a change I can manually make in the plugin to resolve this while we wait for the official update on the January 14, 2014 revision of WP Importer plugin?

This is a 911 status....

Thanks

#21 in reply to: ↑ 20 ; follow-up: @aubreypwd
4 years ago

Replying to unleashyourgeekinc:

Download /trunk directly via http://downloads.wordpress.org/plugin/wordpress-importer.zip and upload (remember to deactivate and remove your current importer plugin) and see if that works. Per @nacin above this is fixed in trunk but just hasn't been tagged for release.

Replying to nacin: Fixed????? This is a show stopper. We are unable to do any imports for any of 100 sites from this. Is there a change I can manually make in the plugin to resolve this while we wait for the official update on the January 14, 2014 revision of WP Importer plugin?

This is a 911 status....

Thanks

#22 follow-up: @unleashyourgeekinc
4 years ago

Thanks! I sincerely appreciate your quick response and the link you provided. I have downloaded the updated plugin and have attempted the import again and it resulted in the same error. I have added logging to my wp-config.php and here is the error that was generated if this helps you get closer to resolving this issue. Here is the error from before the Plugin update:

[16-Jul-2014 19:40:14 UTC] PHP Strict Standards: Redefining already defined constructor for class WXR_Parser_Regex in /var/www/vhosts/bffpetpaintings.com/httpdocs/new/wp-content/plugins/wordpress-importer/parsers.php on line 408 [16-Jul-2014 19:40:14 UTC] PHP Strict Standards: Declaration of WP_Import::bump_request_timeout() should be compatible with WP_Importer::bump_request_timeout($val) in /var/www/vhosts/bffpetpaintings.com/httpdocs/new/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 38

Here is the log file after the update: (I erased old data from the log file to avoid confusion) Empty....:)

No errors were recorded...but I have the same error from the server:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

I am more than happy to work with you to help resolve this. My background is 20 years in exactly this so if it would be helpful to you to access my server or site I welcome you.

Or if there is any specific information that I can provide to you please let me know.

Thanks!

#23 @unleashyourgeekinc
4 years ago

For the sake of providing information that may be helpful to you..

The import I am attempting is on a clean installation of WP and there are no active plugins other than Akismet by default and the theme was default, Twenty Fourteen. I switched it to Classic and it resulted in the same error.

My site is on a dedicated server so we are not affected by limitations of any ISP or hosting company. /etc/php.ini Max Upload is set to 128MB Max Timeout is 120 seconds

This error in importing does occur on every other site we have even with a minimum import size.

If I can provide any other useful information to you please don't hesitate to ask.

#24 in reply to: ↑ 22 @aubreypwd
4 years ago

Replying to unleashyourgeekinc:

I don't think that the new error has to do with the importer plugin you just installed. That might have to do with something else. I just installed the importer using the same .zip with success.

Here is the log file after the update: (I erased old data from the log file to avoid confusion) Empty....:)

No errors were recorded...but I have the same error from the server:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

#25 @unleashyourgeekinc
4 years ago

  • Severity changed from blocker to critical

I agree with you. It is in fact interesting that the first error was related to this post and then after the plugin update the error continued but the specific error and updates to the error log ceased. It's almost like another issue triggered the error (.....Declaration of WP_Import::bump_request_timeout().......) and then after the update the root error was left and the Importer error was resolved. Net result....is some underlying issue.

I guess I have to now open a new post figuring out why I can't generate a Error Debug log to hunt down the root error.

Thank you sincerely for your assistance.

Now to hunt down why this error is occurring. Any ideas? :)

#26 follow-up: @unleashyourgeekinc
4 years ago

Does this help?

I have the debug log active and this error remains on the top of my screen:

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /var/www/vhosts/MYDOMAIN.com/httpdocs/new/wp-includes/functions.php on line 3193

#27 in reply to: ↑ 26 @aubreypwd
4 years ago

Replying to unleashyourgeekinc:

I can't tell if that has anything to do with the importer plugin. Sorry, but I can't help with anything outside of the importer plugin here. Maybe try the support forums and ping me there.

Does this help?

I have the debug log active and this error remains on the top of my screen:

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /var/www/vhosts/MYDOMAIN.com/httpdocs/new/wp-includes/functions.php on line 3193

#28 @rmccue
4 years ago

  • Severity changed from critical to normal

If there's any other issues with the plugin, please file a new ticket or discuss on the forums, as it doesn't appear to be related to the changes here.

#29 follow-up: @ReneHermi
4 years ago

Please merge the patch into new release of the Plugin. I can confirm that it is working after manually patching!

#30 in reply to: ↑ 29 @rezaurc
4 years ago

Replying to ReneHermi:

Please merge the patch into new release of the Plugin. I can confirm that it is working after manually patching!

I'm confirming too. Tested on WordPress version 4.0

#31 @golderweb
4 years ago

I've patched this by my own independently from the diff here and I can confirm that it works with WP 4.0. I also proposed this in this support topic.

#32 in reply to: ↑ 21 @AndrewDon
4 years ago

Thank you much!

Replying to aubreypwd:

Replying to unleashyourgeekinc:

Download /trunk directly via http://downloads.wordpress.org/plugin/wordpress-importer.zip and upload (remember to deactivate and remove your current importer plugin) and see if that works. Per @nacin above this is fixed in trunk but just hasn't been tagged for release.

This ticket was mentioned in Slack in #core by ocean90. View the logs.


3 years ago

#34 @PavelS
3 years ago

It seems author forgot about this plugin. Thread was created 22 month ago and already has a solution.

#35 @LuisaAmbros
3 years ago

I have Wordpress 4.1.1–pt_BR and I'm having the same problem:

Strict Standards: Redefining already defined constructor for class WXR_Parser_Regex in /wp-content/plugins/wordpress-importer/parsers.php on line 408

Strict Standards: Declaration of WP_Import::bump_request_timeout() should be compatible with WP_Importer::bump_request_timeout($val) in /wp-content/plugins/wordpress-importer/wordpress-importer.php on line 38

And after uploading the XML, I got a server error and I believe maybe it is related to this?

#36 @netweb
3 years ago

#31707 was marked as a duplicate.

#37 @archonic
3 years ago

I'm seeing this as well with the latest stable WP.

@jdgrimes
3 years ago

Fix deprecated warnings for WP_Import in PHP7

#38 @jdgrimes
3 years ago

I've just attached wp-import.diff, which fixes additional deprecated warnings that will show up in PHP7 (see #31982).

This ticket was mentioned in Slack in #meta by netweb. View the logs.


3 years ago

#40 @swissspidy
3 years ago

#32959 was marked as a duplicate.

#41 @ocean90
3 years ago

#32960 was marked as a duplicate.

#42 @moonsoup
3 years ago

  • Keywords has-patch removed

I just went to do an svn co to try to push this to the main trunk and it was already done. I don't know if this means that the WordPress version I'm using (latest) is still using old repositories or what... But it appears to be fixed in the main trunk here: http://plugins.svn.wordpress.org/wordpress-importer/ Not sure how that is setup...

#43 @swissspidy
3 years ago

  • Keywords commit dev-feedback removed
  • Resolution set to fixed
  • Status changed from reopened to closed

It looks like it was fixed in May, mentioning #31982.

#44 in reply to: ↑ 11 @netweb
3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to nacin:

Committed to trunk only, it'll go out with a subsequent release.

Replying to ocean90:

Any new plans for this?

Replying to SergeyBiryukov:

Let's keep the ticket open as a reminder.

All of the above still apply, let's keep the ticket open as a reminder and ask again, any plans for a new release?

#45 @SergeyBiryukov
3 years ago

  • Keywords dev-feedback added

#46 follow-up: @nacin
3 years ago

I feel for all of you, but being cognizant of update fatigue, I do not want to release a plugin update to fix a few strict notices. That's giving 5 million people a little orange update bubble and a task to do for absolutely no good reason. This is for a few notices that happen on import, which isn't a common occurrence...

Anyone who cares strongly can silence it for themselves temporarily -- the next release, after all, will overwrite those changes but it'll also contain the fixes.

Now, anyone who cares super strongly can do something else to the importer to make an update worth shipping. Here's a few tickets: https://core.trac.wordpress.org/query?status=!closed&component=Import&summary=~wordpress :-)

#47 in reply to: ↑ 46 ; follow-up: @netweb
3 years ago

Replying to nacin: Makes sense...

Hey @rmccue, have you actually started anything based off of this tweet of yours?

https://twitter.com/rmccue/status/628179606172995584

I haven't touched the importer yet because of the proposed Export API in #22435, once I can actually export what I want exported for bbPress, then update the importer so I can import that data has been my game plan.

#48 in reply to: ↑ 47 ; follow-up: @rmccue
3 years ago

Replying to netweb:

Hey @rmccue, have you actually started anything based off of this tweet of yours?

I have, yes :) Will get that up at some point, just need to get it to semi-usable first.

Only written the parsing stage so far, but on a 41MB WXR file:

  • Old parser: 3.32s, 132.5MB
  • New parser: 3.11s, 19.3MB

This is based on an XML pull parser, specifically XMLReader. This means we process on-the-fly rather than loading the whole thing into memory then doing actions with it. This means slightly tighter coupling between the parser and the processing, but it shouldn't be too bad.

I expect the time will come out a bit faster, but the memory should be significantly reduced.

#49 in reply to: ↑ 48 @netweb
3 years ago

Replying to rmccue:

I have, yes :) Will get that up at some point, just need to get it to semi-usable first.

+1, sweet, let us know if I can help test or what not :)

#50 follow-up: @nofearinc
3 years ago

The issue with Strict Standards has been around for over 2 years now. While it's not a deal breaker for the folks hanging around, it's extremely frustrating and shocking to new users and contributors, and I'm repetitively reassuring some of them at training courses and Contributor Days.

I'm not sure how many of you have to deal with newcomers to WordPress or new not-so-technical contributors, but many of them can't quite comprehend the messages and feel like their website is down, a theme is broken or their server is not configured correctly (I've heard all of those as possible explanations of the issue).

Is there any extremely complicated deployment/update process that keeps postponing this minor update for years, or is it simply undervalued?

#51 in reply to: ↑ 50 @iandunn
3 years ago

Replying to nofearinc:

Is there any extremely complicated deployment/update process that keeps postponing this minor update for years, or is it simply undervalued?

See comment:46

#52 @rmccue
3 years ago

  • Owner set to rmccue
  • Status changed from reopened to assigned

For those of you following along, I've just published more info on the rewrite I've been undertaking, which fixes this and a whole host of other issues.

Leaving this issue reopened until we release an actual version on the plugin repo though.

This ticket was mentioned in Slack in #core by ocean90. View the logs.


2 years ago

This ticket was mentioned in Slack in #core by ocean90. View the logs.


2 years ago

#55 @ocean90
2 years ago

#36987 was marked as a duplicate.

This ticket was mentioned in Slack in #core by jwarren. View the logs.


2 years ago

#57 @yadavji83
2 years ago

It was my first time becoming theme reviewer and i suddenly got this error while trying to import theme data. Wasted time and now found that it's a bug. Hope this gets corrected soon, you may loose people interest this way.

#58 @boonebgorges
22 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

I'm working on an interim release for wordpress-importer and these fixes will be included. See especially https://github.com/boonebgorges/wordpress-importer/commit/a7f368c9c8d9cd5a7abc3450877d7eea57696979, https://github.com/boonebgorges/wordpress-importer/commit/6b95acd04b3b26d9f16c59cf4acc54c913cd8de9

Thanks to all for your patience.

Note: See TracTickets for help on using tickets.