Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24390 closed defect (bug) (duplicate)

Post Formats: Return correct datatype in get_post_gallery()

Reported by: obenland Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Post Formats Keywords: has-patch
Focuses: Cc:


get_post_gallery() has a flag to request HTML or data. By default HTML is requested, yet the fallback data type that is returned by the function assumes that data was requested. This might lead to an array to string conversion if the_post_format_gallery() is being called in a post without a gallery.

Attachments (1)

24390.patch (1.1 KB) - added by obenland 2 years ago.

Download all attachments as: .zip

Change History (3)

@obenland2 years ago

comment:1 @SergeyBiryukov2 years ago

#24393 was marked as a duplicate.

comment:2 @kovshenin2 years ago

  • Milestone 3.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24270.

Note: See TracTickets for help on using tickets.