WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 9 months ago

#24395 closed defect (bug) (wontfix)

Remove PollDaddy oEmbed support -- PollDaddy no longer supports oEmbed

Reported by: justinph Owned by:
Milestone: Priority: high
Severity: normal Version: 3.6
Component: Embeds Keywords:
Focuses: Cc:

Description

After some befuddling experiences, I contacted PollDaddy to ask why their oEmbed support was not working, since it's built-in. Polldaddy confirmed for me that they no longer support oEmbed:

Hi,

Wordpress has polldaddy oEmbed support hard-coded to look for your oEmbed
provider at http://polldaddy.com/oembed/, but it looks like that page is
currently a 404. This is making bad things happen for lots of people
worldwide using wordpress and trying to embed polldaddy polls. 

If you could look into this, that'd be great. 

Hi Justin,

We've not supported oEmbed for over a year now. If you want to embed a 
Polldaddy poll you will need to use our WordPress plugin, or one of the other
Polldaddy embed methods.

Thanks,
-- 
John Godley
Automattic | Polldaddy | WordPress.com

-- 
john

Thus, attached is a patch to remove polldaddy support from core.

Attachments (1)

remove-polldaddy-oembed.diff (1.1 KB) - added by justinph 11 months ago.
patch to remove polldaddy support

Download all attachments as: .zip

Change History (3)

justinph11 months ago

patch to remove polldaddy support

comment:1 nacin11 months ago

  • Keywords has-patch removed
  • Priority changed from normal to high

We're asking Polldaddy to add back oEmbed support.

comment:2 nacin9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Polldaddy oEmbed support came back.

Note: See TracTickets for help on using tickets.