WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 10 months ago

Last modified 10 months ago

#24432 closed defect (bug) (invalid)

On multisite when SSL active on page: 'http' $scheme not working in get_admin_url(), but works in get_site_url()

Reported by: Just a guy Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Multisite Keywords:
Focuses: Cc:

Description

get_site_url() wp-includes/link-template.php, line 1964
get_admin_url() wp-includes/link-template.php, line 2006

In multisite specifying 'http' $scheme in get_admin_url() has no effect, links are still served as https. Yet, specifying 'http' $scheme in get_site_url works fine.

As a workaround, use: get_site_url($blog_id, 'wp-admin/', 'http') until get_admin_url fixed.

Change History (4)

comment:1 Just a guy11 months ago

  • Summary changed from Multisite: 'http' $scheme not working in get_admin_url(), but works in get_site_url() to On multisite when SSL active on page: 'http' $scheme not working in get_admin_url(), but works in get_site_url()

I just want to specify that this happens 1) on multisite and 2) when used on an https page. I haven't tested this on an http page when trying to set the URL to https.

comment:2 SergeyBiryukov10 months ago

  • Component changed from General to Multisite
  • Keywords reporter-feedback added

Could not reproduce on a clean Multisite install neither in 3.5.1 nor in trunk.

Do you have a filter hooked to 'admin_url' somewhere?

comment:3 Just a guy10 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Hi Sergey, thanks, I think you're right. I tested this multiple times with all plugins disabled, default themes etc and could reproduce, but now I can't reproduce it with a theme install either. It appears I was mistaken, I'll close this ticket.

comment:4 SergeyBiryukov10 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.