Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24436 closed defect (bug) (duplicate)

menu does not import hierarchy consistently of categories

Reported by: allergicvegetarian Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Menus Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

I have typed in lots of categories but when I go to menu, sometimes the hierarchy I have chosen for the category item sticks, other times I see them mixed up and NOT in the hierarchy format, under the Parent Category I chose for it. I'm doing a complicated Recipe site, with every allergy diet type, under its own allergy category with sub-categories, which is part of the problem. Your cool software assumes simplistic, "normal" organization. Unfortunately, I'm way beyond "normal". ;)
For example:
Instead of

Corn Allergy
--Corn Allergy Main Course
----Corn Allergy Pasta
----Corn Allergy Rice
--Corn Allergy Bakery
----Corn Allergy Bread
----Corn Allergy Desserts

I'll see: Mixed up completely!

Corn Allergy
Corn Allergy Bakery
Corn Allergy Main Course
Corn Allergy Other
Corn Allergy Breads
Corn Allergy Desserts
Corn Allergy Condiments and Sauces

For me, this totally breaks my site (Critical) and makes me want to go back to hardcoding (not cool) and NOT using Wordpress but I listed Severity as Major because most people do NOT do what I do.

Change History (2)

comment:1 @SergeyBiryukov2 years ago

  • Description modified (diff)

comment:2 @SergeyBiryukov2 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18282, #19837, and #20351.

Note: See TracTickets for help on using tickets.