WordPress.org

Make WordPress Core

#24440 closed defect (bug) (duplicate)

despite limiting add_theme_support post-formats, all formats are displayed on posts and cpts

Reported by: ryno267 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Post Formats Keywords: needs-docs needs-codex
Focuses: Cc:

Description

Example is there are only 4 post formats that are added to add_theme_support, but all display on add new post and add new custom post type.

add_theme_support( 'post-formats', array( 'image', 'video', 'audio', 'link' ) );

Also have custom post type code that adds 'post-formats' to 'supports'

'supports' => array( 'title', 'editor', 'thumbnail', 'post-formats'),

Regardless of that, all 10 post formats are shown on add new posts and the 'add new' CPT I added support to.
Should it not only display those 4?

Change History (3)

comment:1 johnbillion11 months ago

  • Keywords needs-docs added

This is intentional, but there needs to be some documentation to make this clear to developers.

See: #19570, #23347

comment:2 sunnyratilal11 months ago

  • Keywords needs-codex added

comment:3 SergeyBiryukov11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23718, #23844, and #23990.

Related: #24059

Note: See TracTickets for help on using tickets.