WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 3 months ago

#24470 closed defect (bug) (invalid)

Fire Fox 21.0 FireBug Reporting Error from jquery.js?ver=1.8.3

Reported by: robert.lang Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

After searching, there appears to be no previous reporting of this issue. I believe it is being caused by a recent update to the Fire Fox Browser after 3.5.1 release. I haven't seen it come up before FF V. 21.0.

uncaught exception: DataCloneError: The object could not be cloned.
https://website.com/wp-includes/js/jquery/jquery.js?ver=1.8.3
Line 2

This error is consistent on return url after payment is processed via PayPal. As many as 92 cyclical references.

Some references for a solution:

http://stackoverflow.com/questions/7506635/uncaught-error-data-clone-err-dom-exception-25-thrown-by-web-worker

The original exception was most likely thrown because you tried passing a host object to the web worker (most likely a dom element). Your subsequent attempts don't throw the same error. Remember two key points: there isn't shared memory between the different threads, and the web workers can't manipulate the DOM.

postMessage supports passing structured data to threads, and will internally serialize (or in some other way copy the value of the data recursively) the data. Serializing DOM elements often results in circular reference errors, so your best bet is to map the object you want serialised and extract relevant data to be rebuilt in the web worker.

Further Explanation to this cause:

https://developer.mozilla.org/en-US/docs/Web/API/Worker?redirectlocale=en-US&redirectslug=DOM%2FWorker#postMessage%28%29


Change History (3)

comment:1 markoheijnen11 months ago

How do you get this error? To me it seems that the error is caused by a plugin and that there isn't much for us to solve that.
Also can you try running trunk version of WordPress which includes a newer version of jQuery (1.10.0).

comment:2 SergeyBiryukov10 months ago

  • Keywords reporter-feedback added; needs-patch removed

comment:3 nacin3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.