WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#24527 closed enhancement (worksforme)

one (or none at all) click media insertion

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: ui Cc:

Description

to insert a media to a post you need to

  1. click on the insert media button
  2. click on the "upload" button
  3. select image
  4. insert into post

Why do we have step 1 and 4? why can't we have a "direct upload" button which opens a file selection dialog and insert it directly to the post when files are selected? People can always edit the media properties after the insertion if needed.

Even better, just let me drag files to the editing area.

Change History (5)

#1 @sabreuse
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19845.

#2 @mark-k
6 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

while similar, the ticket is not the same. This ticket is not about the technical solution, but about improving the workflow for inserting a media file from the PC into a post, something that I do all the time. Right now there is a workflow which serves picking media from the media library at the same priority or higher then uploading a file directly into a post, but IMO bloggers don't use the media library and the process as it is now just makes a basic task needlessly more complex for them.

#3 @SergeyBiryukov
6 years ago

  • Milestone set to Awaiting Review

#4 in reply to: ↑ description @ericlewis
5 years ago

  • Focuses ui added
  • Resolution set to worksforme
  • Status changed from reopened to closed
  • Version set to 3.5

Replying to mark-k:

Even better, just let me drag files to the editing area.

A feature of WordPress 3.9 "Smith": Drag and drop your images

#5 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.