WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 months ago

#24545 closed defect (bug) (duplicate)

Fix Admin Layout When Displaying Errors

Reported by: sunnyratilal Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Administration Keywords:
Focuses: ui, administration Cc:

Description

Whenever a PHP error is displayed in the backend, it causes WordPress layout to screw up on the options pages by enlarging the font size and pushing the footer up to the bottom of the viewport so that it's not at the bottom of the page, instead, the bottom of the screen up so when you scroll to the bottom of the page, it's actually 3/4 way or 1/2 way up the page.

Attachments (2)

Screen Shot 2013-06-09 at 16.12.09.png (123.1 KB) - added by sunnyratilal 7 years ago.
Screen Shot 2015-08-07 at 02.05.10.png (234.0 KB) - added by johnbillion 5 years ago.

Download all attachments as: .zip

Change History (14)

#1 @mordauk
7 years ago

  • Cc pippin@… added

#2 @sunnyratilal
7 years ago

  • Cc sunny@… added

#3 @alexvorn2
7 years ago

  • Cc alexvornoffice@… added

#4 @SergeyBiryukov
7 years ago

Some work in this direction was done in #19196.

See ticket:19196:19196.2.patch and ticket:19196:19196.after.png, also ticket:19196:8.

Last edited 7 years ago by SergeyBiryukov (previous) (diff)

#5 @SergeyBiryukov
7 years ago

  • Component changed from Appearance to Administration

#6 @nacin
7 years ago

  • Version changed from trunk to 3.2

#7 @helen
7 years ago

  • Focuses ui added
  • Keywords needs-ui ui-feedback removed

#8 @johnbillion
5 years ago

  • Focuses administration added

This behaviour/appearance is really detrimental to developers trying to debug things in environments where they have no choice but to display errors in the browser.

The sticky/folding sidebar behaviour might make this more difficult, but it would be great to not cover up the left hand portion of anything output outside of the #wpcontent div.

Who wants to tackle this?

#9 @afercia
5 years ago

Related: #28376 and #35155.

#10 @valentinbora
8 months ago

  • Milestone set to 5.5

#11 @audrasjb
6 months ago

  • Keywords needs-patch removed

Hi, for information, there is a patch for this in #35155.

#12 @johnbillion
6 months ago

  • Milestone 5.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #35155 because that one has a patch.

Note: See TracTickets for help on using tickets.