WordPress.org

Make WordPress Core

#24560 closed defect (bug) (worksforme)

Error in 'get_default_post_to_edit' when creating new posts

Reported by: metaltoast Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Administration Keywords:
Focuses: Cc:

Description

In 3.6-beta3-24432, when visiting post-new.php to create a new post the blue 'Publish' button is replaced by a 'Submit for Review' button. I initially thought it was a user permissions error but the backtrace script shows the following error:

sitepath/wp-admin/post-new.php 52 calling get_default_post_to_edit()

When clicking 'Submit for Review', a blank post is created which shows up on the frontend and on the RSS feed but is undeletable from the admin section as no edit link or checkbox is available on edit.php.

Also, the issue exists through XMLRPC (I've tried with the iPhone and iPad apps).

Change History (6)

comment:1 @nacin22 months ago

  • Keywords reporter-feedback added

Can you elaborate on the error? What you posted looks like a piece of a call stack (X function called from Y location) but I don't see an error or how get_default_post_to_edit() is involved.

Do you have any plugins enabled?

comment:2 @SergeyBiryukov22 months ago

  • Keywords reporter-feedback removed

Could not reproduce on a clean install.

Issues like this can be a sign of a corrupted database. Running a repair on all tables should help in that case.

comment:3 @SergeyBiryukov22 months ago

  • Keywords reporter-feedback added

comment:4 @metaltoast22 months ago

I don't believe it was something to do with the database as there weren't any errors I could see. I've just wiped my copy and started with a clean install. All works now.

comment:5 @metaltoast22 months ago

  • Keywords close added

comment:6 @SergeyBiryukov22 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.