WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 9 months ago

#24573 closed enhancement (wontfix)

File URL in Media Upload

Reported by: puneetsahalot Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Media Keywords: ux-feedback
Focuses: Cc:

Description

Display a "details" link in addition to "edit" link after the file upload is complete.
Clicking edit link, switching to a new tab/window to find out the URL of uploaded file is annoying for a lot of users.
A "details" link can work inline and display file URL and basic information like dimensions, attachment URL etc.
Those who REALLY need to edit the file may use "edit" link.

Change History (4)

comment:1 @SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23564.

comment:2 @SergeyBiryukov2 years ago

  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened

On second thought, looks like this applies to "Upload New Media" screen rather than the media modal.

Related: [22755] (for #22083).

comment:4 @wonderboymusic9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

Since Media Grid, /wp-admin/media-new.php is not a priority for more love. It is really only still around for back-compat. There has been no love for this enhancement in 16 months.

Note: See TracTickets for help on using tickets.