WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24599 closed defect (bug) (fixed)

Twenty Thirteen: Horizontal scrollbar appears in large viewports

Reported by: gorgoglionemeister Owned by: lancewillett
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description (last modified by obenland)

Starting from 1600 pixels up to 1614 pixels viewport width, the page (.site) width is 2 pixels wider than the body width, causing an horizontal scrollbar to appear. It seems to be caused by the following rule:

.site {
	-webkit-box-sizing: content-box;
	-moz-box-sizing: content-box;
	box-sizing: content-box;
}

which I don't understand why it has been introduced as of changeset [23962].

Attachments (1)

24599.diff (518 bytes) - added by obenland 2 years ago.
In case a patch is needed.

Download all attachments as: .zip

Change History (9)

comment:1 @helen2 years ago

  • Summary changed from Horizontal scrollbar appears in large viewports to Twenty Thirteen: Horizontal scrollbar appears in large viewports

comment:2 @SergeyBiryukov2 years ago

  • Description modified (diff)

comment:3 follow-up: @obenland2 years ago

  • Description modified (diff)
  • Milestone changed from Awaiting Review to 3.6

Reproducible on http://twentythirteendemo.wordpress.com/ as described above.

The box-sizing change was to fix navbar border styles for viewports at 1600 pixels wide and above, and IIRC for when the navbar was fixed. Since we dont have a fixed navbar anymore, we can probably remove the style.

@obenland2 years ago

In case a patch is needed.

comment:4 @obenland2 years ago

  • Keywords has-patch added

comment:5 in reply to: ↑ 3 ; follow-up: @gorgoglionemeister2 years ago

Replying to obenland:

Reproducible on http://twentythirteendemo.wordpress.com/ as described above.

The box-sizing change was to fix navbar border styles for viewports at 1600 pixels wide and above, and IIRC for when the navbar was fixed. Since we dont have a fixed navbar anymore, we can probably remove the style.

IIRC means if I recall correctly?

comment:6 @lancewillett2 years ago

  • Keywords commit added

comment:7 in reply to: ↑ 5 @obenland2 years ago

  • Keywords commit removed

Replying to gorgoglionemeister:

IIRC means if I recall correctly?

Whops, yes :)

Version 0, edited 2 years ago by obenland (next)

comment:8 @lancewillett2 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 24513:

Twenty Thirteen: remove box-sizing styles from site wrapper element to avoid horizontal scrollbars in large viewports. Fixes #24599, props obenland.

Note: See TracTickets for help on using tickets.