WordPress.org

Make WordPress Core

#24609 closed defect (bug) (duplicate)

Media files can’t be inserted as downloadable link

Reported by: derekspringer Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Media Keywords: has-patch
Focuses: Cc:

Description

Linking to the media file creates the shortcode/player. Various users in tickets and forums report that they want to still have the option to NOT include the player.

Steps to reproduce:

  1. New Post
  2. Add Media
  3. Select or upload an audio or video file
  4. Under Attachment Display Settings, change the Link To dropdown to “Media File” (or anything but "None")
  5. Click insert into post

Result: the shortcode to include a player is inserted rather than just the file link. You get the same result when you choose a different attachment setting option like: attachment page, media file or custom url.

Attachments (1)

wp_ajax_send_attachment_to_editor.diff (1.1 KB) - added by derekspringer 10 months ago.
Patch for wp_ajax_send_attachment_to_editor() function to allow inserting links to media instead of shortcode.

Download all attachments as: .zip

Change History (4)

derekspringer10 months ago

Patch for wp_ajax_send_attachment_to_editor() function to allow inserting links to media instead of shortcode.

comment:1 follow-up: SergeyBiryukov10 months ago

Sounds like a duplicate of #24449.

comment:2 in reply to: ↑ 1 ; follow-up: derekspringer10 months ago

Replying to SergeyBiryukov:

Sounds like a duplicate of #24449.

Looks like you are correct, shall I post my patch over there? I just fixed this same issue over on WordPress.com

comment:3 in reply to: ↑ 2 helen10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24449.

Replying to derekspringer:

Looks like you are correct, shall I post my patch over there? I just fixed this same issue over on WordPress.com

Yes please. And YAY.

Note: See TracTickets for help on using tickets.