WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#24625 closed defect (bug) (worksforme)

"File not found" in admin area after upgrade from 3.5.1 to 3.5.2

Reported by: _doherty Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.2
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

After upgrading Wordpress from 3.5.1 to 3.5.2, my blog's admin area became inaccessible.

Requests for any page inside wp-admin resulted in "File not found". In the server logs, I saw 'FastCGI sent in stderr: "Primary script unknown"'. Wordpress content pages were served normally.

Server configuration was not changed as part of this upgrade.

After reverting the upgrade, the admin area became accessible again. I repeated the upgrade, and it failed a second time.

Change History (7)

#1 @bpetty
3 years ago

  • Version changed from trunk to 3.5.2

#2 follow-up: @bpetty
3 years ago

Can you provide any additional details?

What are the file permissions of wp-admin/index.php and wp-login.php compared with index.php?

Are you performing a manual upgrade (FTP/SCP) or an automatic upgrade?

#3 in reply to: ↑ 2 @_doherty
3 years ago

Replying to bpetty:

What are the file permissions of wp-admin/index.php and wp-login.php compared with index.php?

$ ll wp-admin/index.php wp-login.php 
-rw-r--r-- 1 www-data admin  6436 Dec 14  2012 wp-admin/index.php
-rw-r--r-- 1 www-data admin 29310 Jun 23 01:00 wp-login.php

Are you performing a manual upgrade (FTP/SCP) or an automatic upgrade?

Automatic, from within the application.

Version 0, edited 3 years ago by _doherty (next)

#4 @_doherty
3 years ago

  • Cc _doherty added

#5 @_doherty
3 years ago

When I log in, I get a 302 to /wp-admin/. This in turn gives me a 302 to /wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F.

In fact, any requests to /wp-admin/anything.php are redirected to /wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2Fanything.php

/wp-admin/upgrade.php is a 404, with the error described above in the logs.

#6 @nacin
3 years ago

This sounds like a server issue, and not something WP did or could fix. wp-admin/upgrade.php should exist — check?

#7 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I second it being a server configuration.
Please re-open if you can provide the exact circumstances for someone else to trigger it.

Note: See TracTickets for help on using tickets.