WordPress.org

Make WordPress Core

#24634 closed defect (bug) (worksforme)

iframes and embeds not working

Reported by: adamdanielmedia Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.2
Component: Embeds Keywords:
Focuses: Cc:

Description

Since upgrading to WP 3.5.2 my embedded Bandcamp players, which use frames, aren't displaying correctly.

Example page is www.adamdaniel.com/music/blue-pop

Change History (9)

comment:1 nacin10 months ago

How are you embedding these players? Are you pasting in the iframe/embed code?

comment:2 adamdanielmedia10 months ago

Tried two ways: pasting in the iframe code, and using a WP.com short code after activing Jetpack.

Bandcamp just upgraded their players. Thinking the bug could be theirs, I just went back to the iframe code for their old players. Same problem, which makes me wonder if it's a WP issue.

comment:3 nacin10 months ago

If a shortcode is also broken, then this is very likely an issue with Bandcamp. But I was also able to embed an iframe from Bandcamp fine on 3.5.2. I'm guessing you are using a user that has the ability to use unfiltered_HTML (administrator/editor)?

comment:4 adamdanielmedia10 months ago

I am, yes. I don't use the visual tab at all.

Weird, when I refresh a page with a player, suddenly it renders alright. But on first load, it bugs.

comment:5 nacin10 months ago

If the first load is a preview, then this is a duplicate of #20148.

comment:6 adamdanielmedia10 months ago

No, not a preview. Wish it were that easy. :)

comment:7 adamdanielmedia10 months ago

Even weirder, when I hover over the parts of the Bandcamp player that are rendering, they vanish.

comment:8 SergeyBiryukov10 months ago

  • Component changed from General to Embeds

comment:9 nacin10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I think it would be best if this gets kicked into the support forums for now: http://wordpress.org/support/. If a bug is found, please feel free to re-open.

Note: See TracTickets for help on using tickets.