WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#24649 closed defect (bug) (duplicate)

WP_Terms_List_Table displays empty pages with large hierarchical taxonomy

Reported by: csixty4 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0
Component: Taxonomy Keywords:
Focuses: Cc:

Description

I have a hierarchical taxonomy with 1,222 terms (oy!). In the admin (wp-admin/edit-tags.php?taxonomy=business_areas), the first five pages of terms display correctly (at 20 terms per page). But the sixth page on just show an empty table -- no terms.

Commenting out these lines in class-wp-terms-list-table.php prevents the empty display, but breaks the hierarchy:

if ( $term->parent != $parent && empty( $_REQUEST['s'] ) ) {
	continue;
}

Then I get a list like:

Musical Instruments and Repairs
— Brass Instruments and Repairs
— Bricklaying Services

…which tells me the terms are getting sorted by name, irrespective of the hierarchy. That might ultimately be the source of the problem.

Change History (2)

comment:1 csixty410 months ago

  • Keywords dev-feedback removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14485.

Worked around this by calling delete_option('business_areas_children') at the end of the import so the cache gets rebuilt correctly.

comment:2 SergeyBiryukov10 months ago

  • Milestone Awaiting Review deleted
  • Version changed from 3.5.2 to 3.0
Note: See TracTickets for help on using tickets.