WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#24677 closed defect (bug) (invalid)

link_category is broken

Reported by: cfoellmann Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.2
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

Reproducing the problem

Activate the legacy Link Manager via

add_filter( 'pre_option_link_manager_enabled', '__return_true' );

and create a Category for the "Links" post type.

Problem

The link to show the category in the list of categories results in this:

<blog-url>/?taxonomy=link_category&term=some-name

My permalink structure is

/%postname%/

Also: Shouldn't the activation add a field to Permalinks > Optional?

I never used the links/blogroll in old versions until now. So I don't really know what the correct behavior is.

Change History (4)

comment:1 @cfoellmann2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 @SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted

To be clear:

  1. "Links" is not an actual post type, it's a separate structure (see #18781).
  2. link_category is registered with 'rewrite' => false, so the URL is correct.

comment:3 follow-up: @markoheijnen2 years ago

The problem here is that you still have a "View" link. That is confusing since it does not work.

comment:4 in reply to: ↑ 3 @SergeyBiryukov2 years ago

Replying to markoheijnen:

The problem here is that you still have a "View" link. That is confusing since it does not work.

Indeed, see #24692.

Note: See TracTickets for help on using tickets.