Make WordPress Core

Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#2470 closed defect (bug) (wontfix)

<strike> sucks, <del> does not

Reported by: viper007bond's profile Viper007Bond Owned by: markjaquith's profile markjaquith
Milestone: Priority: low
Severity: minor Version: 2.0.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

<strike> was deprecated in HTML 4.01 and is not supported XHTML 1.0 Strict DTD or XHTML 1.1, so it shouldn't be allowed in comments, at least by default.

Attachments (1)

no_more_strike.diff (390 bytes) - added by Viper007Bond 16 years ago.
Replacement of strike with del in allowed comment tags

Download all attachments as: .zip

Change History (9)

@Viper007Bond
16 years ago

Replacement of strike with del in allowed comment tags

#1 @davidhouse
16 years ago

  • Keywords bg|2nd-opinion added

+1, but I'm marking with 2nd-opinion.

#2 @markjaquith
16 years ago

  • Keywords bg|commit added; bg|2nd-opinion removed
  • Milestone set to 2.1
  • Owner changed from anonymous to markjaquith
  • Priority changed from normal to low
  • Severity changed from normal to minor
  • Status changed from new to assigned

If it breaks XHTML 1.0 strict validation, we should axe it.

+1

#3 @matt
16 years ago

The problem is del is both an inline and block level tag, and can seriously mess up page layouts if allowed.

#4 @markjaquith
16 years ago

Same problem with &lt;ins&gt; ... currently, you can't use &lt;ins&gt; as block level in WP.

#5 @foolswisdom
16 years ago

Is the appropriate thing just to remove <strike> and not replace it with <del>?

#6 @Nazgul
16 years ago

  • Keywords has-patch added; bg|has-patch bg|commit removed

#7 @matt
15 years ago

  • Resolution set to wontfix
  • Status changed from assigned to closed

#8 @Nazgul
15 years ago

  • Milestone 2.1 deleted
Note: See TracTickets for help on using tickets.