WordPress.org

Make WordPress Core

#24701 closed defect (bug) (duplicate)

Poorly formed CDATA section in RSS feed

Reported by: jphekman Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Feeds Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Discovered at http://ilaba.wordpress.com/feed/ -- apparently WordPress does not strip out control characters when generating CDATA sections in the RSS feed for blogs at wordpress.com. As a result, if an author includes a control character (in this case, ^L) in their post, the CDATA section that is wrapped around the post content will be poorly formed. Therefore, the XML document for the feed will not be well formed, and therefore not parsable by many XML parsers.

The feed in question was not parsable on scienceseeker.org on 7/6/13, which is why I am interested in the question. It may be corrected by its owner by the time you test it, so I am attaching a copy of the broken version to this ticket.

Attachments (1)

ilaba.xml (113.1 KB) - added by jphekman 23 months ago.
Wordpress-generated RSS file which is not well formed

Download all attachments as: .zip

Change History (2)

@jphekman23 months ago

Wordpress-generated RSS file which is not well formed

comment:1 @SergeyBiryukov23 months ago

  • Component changed from General to Feeds
  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19998.

Note: See TracTickets for help on using tickets.