WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 7 weeks ago

Last modified 7 weeks ago

#24710 closed enhancement (duplicate)

make the UX of media upload via the media library similiar to the one via post editing

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: ui, administration Cc:

Description

The changes in 3.5 degraded the user experience when uploading new files to the media library. In 3.4 after the upload was finished you could edit at the same screen some of the properties of an image, for example its title. In 3.5 you need to open a new tab/window to do that which takes more time when uploading several images at once.

In contrast, when uploading images via the "add media" when editing posts, you can change properties from the same window.

IMO the media library upload should behave almost exactly like the post "add media".

Change History (3)

comment:1 helen5 months ago

  • Focuses ui administration added

Yeah, media-new.php never got any real treatment. That ugly table is what was there before, but without the toggle to edit. Maybe it would be good to explore this some more in something like the Media Library Grid View plugin (not super actively being developed, but a thought), or maybe we don't need a separate add new screen at all, but a drop zone on media.php instead.

comment:2 ericlewis7 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24716.

comment:3 DrewAPicture7 weeks ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.