Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24717 closed defect (bug) (duplicate)

Image editor do not update custom image sizes when the main image is modified.

Reported by: Fab1en Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.2
Component: Editor Keywords:
Focuses: Cc:


In the Media Library, images can be edited directly in WP : you can crop them, rotate and so on. You can also decide to apply changes to the main image only, the thumbnails only or to all sizes.
But even when applied to all sizes, only thumbnail, medium and large size are updated. Size added via add_image_size are not changed.

I thought this was a feature to implement, but when digging in the code, I saw that the custom image sizes are taken care of. There is just a small bug that prevents the sizes to be set correctly, hence the resizing process fails for those sizes.

I will submit a patch to correct this.

Attachments (1)

Get-custom-image-size-from-a-global-object.patch (2.0 KB) - added by Fab1en 2 years ago.
Proposed correction patch

Download all attachments as: .zip

Change History (2)

@Fab1en2 years ago

Proposed correction patch

comment:1 @markoheijnen2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19889.

Note: See TracTickets for help on using tickets.