WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

#24755 closed defect (bug) (fixed)

Multiple copies of backup-post-in-browser-different message

Reported by: markjaquith Owned by:
Milestone: 3.6 Priority: high
Severity: critical Version: 3.6
Component: Autosave Keywords:
Focuses: Cc:

Description

http://f.cl.ly/items/1b2k2l2r0g3G2D3p0j1f/Screen%20Shot%202013-07-14%20at%205.17.17%20PM.png

Via: http://wordpress.org/support/topic/browser-post-version-check?replies=2

At most, this message should show up once.

Attachments (1)

24755.patch (516 bytes) - added by azaozz 9 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 azaozz9 months ago

Can't reproduce either. There is something weird going on at that site. The call to the function that displays the error message is hard-coded (see here and here). Not sure how it can run multiple times unless the actual autosave.js file is loaded multiple times.

Looking at the screencast there is a plugin (or several plugins) extending TinyMCE. May have something to do with this.

comment:2 azaozz9 months ago

Actually multiple copies of the error message will be inserted if there are more than one <h2> at the top of the page. Can reproduce when there are 14 <h2>'s and only the first is visible. Not sure what could be adding them.

Last edited 9 months ago by azaozz (previous) (diff)

azaozz9 months ago

comment:3 markjaquith9 months ago

In 24710:

Only add the autosave notice to the first <h2> on the page.

Props azaozz. See #24755.

comment:4 nacin9 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Closing as fixed, pending further forum feedback.

Note: See TracTickets for help on using tickets.