WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 20 months ago

#24762 closed enhancement (duplicate)

Better insertion of remote audio/video via URL from the media modal

Reported by: ericlewis Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Media Keywords: ui-feedback ux-feedback
Focuses: Cc:

Description

In 3.6, shortcode support for adding video and audio media has been added, as well as just dropping the link on a line of a post. However, users who don't read documentation won't be aware of these.

Adding this functionality to the media modal could bring this to the user's attention.

Change History (4)

comment:1 follow-up: @helen2 years ago

The shortcode does get inserted from the modal, as far as functionality goes.

Semi-related: #15490

comment:2 in reply to: ↑ 1 @ericlewis2 years ago

Replying to helen:

The shortcode does get inserted from the modal, as far as functionality goes.

I was testing with remote embeds from the "Insert from URL" panel, which wraps the URL with a link and puts it into the post. Sorry, should've been clear about that.

comment:3 @helen2 years ago

  • Summary changed from Add audio/video UI in the editor or media modal to Better insertion of remote audio/video via URL from the media modal

Then #15490 is definitely related. :) Maybe even a bit of a duplicate, as it addresses not linking the URL if the response is valid so that oEmbed can kick in.

comment:4 @helen20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15490.

Gonna go ahead and close as a dupe. Feel free to reopen if there's more to it.

Note: See TracTickets for help on using tickets.